This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » Problem with Debug
expandshrink

Problem with Debug

Problem with Debug

Monday 26 December 2011 10:50:57 am - 9 replies

I have a problem with my debugs:

after having enter the code

DebugOutput=enabled

I get an error. and i dont have any display in my site page.

If i change it to desabled , it shows the web page. i dont have at all any information about my templates and debugs.what should i do?

I have tried to enter these in my site.ini.append.php in override folder

 

[DebugSettings]

DebugOutput=enabled 

[TemplateSettings]

TemplateCache=disabled

TemplateCompile=disabled

 [ContentSettings]

ViewCaching=disabled

StaticCache=disabled

 

 

 

but the site admin disappeared.then i tried to enter these codes in my site.ini.append.php in my siteaccess:

 

 

 

[DebugSettings]DebugOutput=enabled

DebugToolbar=disabled

AlwaysLog[]=warning

AlwaysLog[]=debug

AlwaysLog[]=notice

AlwaysLog[]=strict
[TemplateSettings]DevelopmentMode=enabled

ShowUsedTemplates=enabled

TemplateCache=enable
[OverrideSettings]

Cache=enabled

 

and as i said my web page disapperared!

and in any case, my Quick Settings window doent work! 

what should i do?

Modified on Monday 26 December 2011 2:25:23 pm by nazanine ahmadi

Monday 26 December 2011 1:51:46 pm

Hi,

Activating debug mode should be in site.ini.append.php, not in override.ini.append.php, as you mentioned it.

Did you try check the HTML source code? eZ log files?

Jean-Luc.

Monday 26 December 2011 3:23:36 pm

Sorry i mean site.ini.append.php inside of override , but any way doesnt work! 

Monday 26 December 2011 3:50:58 pm

Hi,

Did you check the log files if there is something wrong? (YOUR_EZ_ROOT_DIR/var/log/)

Monday 26 December 2011 6:26:53 pm

in my error.log i dont have any error about debug , 

but i have a___ debug.log____ , i dont know if it should be there or not! 

which is full of these two error:

 

ezxFormToken::input:Input not protected (not POST)

 ezxFormToken:omg.gif Emoticonutputomg.gif Emoticonutput not protected (not logged in user)

Tuesday 27 December 2011 9:29:09 am

Hi,

I think you should desactivate all your extensions first, then check this list:

http://www.acidre.com/blog/ez-publish-vs-bug-la-checklist-update/

Tuesday 27 December 2011 8:33:26 pm

@nazanin: the debug.log file is produced by ez, when you activate it using the Alwayslog[] setting in site.ini. eZ Generates various log files if asked to, with messages ranging from very critical to purely informational.

The ezxFormToken messages in debug.log are not warning but pure debug information; they are generated by the ezformtoken extension that you have enabled

Monday 02 January 2012 10:20:08 am

thanks for ur answers

but i have still my problem!

when i enable my debug in site.ini.append.php

in my error log i have this :

 

eZINI::loadCache:Input file "settings/siteaccess/beeSite/site.ini.append.php" has a timestamp higher then current time, ignoring to avoid infinite recursion!

 

and when i enter the code in site.ini.append.php in override it gives me this error:

 

eZTemplate:ezini:!!!No such variable 'SiteName' in group 'SiteSettings' for Site.ini[ Jan 02 2012 10:10:48 ] eZTemplate @ extension/ezBee/design/beeDesign/templates/parts/header.tpl:33[97]:Unknown template variable 'search_text' in namespace ''

Monday 02 January 2012 10:39:00 am

Hello nazanin,

I've never had this problem myself but I did a quick search here in the forums and found this helpful reply to another having a similar problem before. It seems you should heed Gaetano Giunta advice, shared here,

http://share.ez.no/forums/install-configuration/fatal-error-ez-publish-did-not-finish-its-request4#comment69859

 

I hope this helps ...

 

Cheers,

Heath

Monday 02 January 2012 2:49:26 pm

thank you for ur answer:

But how can i change timestamp and where are them?

in my php file i have already changed max_execution_time on 300 and memory_limit value to 256M.

but i have still this error when i add these codes in my site.ini.append.php

[DebugSettings]DebugOutput=enabled

DebugRedirection=disabled
[TemplateSettings]

DevelopmentMode=enabled

Debug=disabled

ShowXHTMLCode=enabled

ShowUsedTemplates=enabled
[DatabaseSettings]

SQLOutput=disabled

 

[ Jan 02 2012 14:37:10 ] [192.168.1.228] eZINI::loadCache:Input file "settings/override/site.ini.append.php" has a timestamp higher then current time, ignoring to avoid infinite recursion!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from