eZ Community » Forums » Install & configuration » Questions about Multi-Site
expandshrink

Questions about Multi-Site

Questions about Multi-Site

Monday 19 May 2008 11:11:12 am - 9 replies

Hello together,

I have installed EZ Publish 4.0 on my PC to test the functionallity of Multi-Site. I am searching arount the forum and documentation how to setup such a multi site. Without success.

Is there a documentation how to do this? I have only found several topics for the version 3.x but not for 4.0. Could you please give me some tips? Either in english or in german.

best regards,
Stefan

Monday 19 May 2008 11:18:22 am

The basic haven't changed much from ezp 3.x to 4.x, you still set up several site-accesses and configure them to use different parts of the node tree and/or different language and/or different database and/or different design.

Monday 19 May 2008 11:51:00 am

Ok, what I have done is following:

1. I have created a copy of an existing folder in siteaccess and changed the site.ini.append.php

2. I have signed in to the backend and defined a new policy for the anonymous role (user/login/siteaccess)

3. Now I can view this new site with http://localhost/ez/index.php/xxx/

But how can I login into the Backend of this site? If I login, I allways get the administration of the "Default site".

Monday 19 May 2008 12:13:51 pm

Currently they share back end, if you want the two sites to be independent of each other, then make a copy of the back end siteaccess as well (normally something like "*_site_admin"blunk.gif Emoticon.

Then modify each of the siteaccesses for "site2" to use another database(this can be a copy of the one you already use), and another var folder(a copy of the original one if you copy the database).

Monday 19 May 2008 1:17:35 pm

First of all.... thank you very much for your help. Just one little question: You wrote that the back end shares the sites. That's no problem for me. But how can I change the content of the new site in the back end? I only have the translations which I can change. What did I wrong?

Monday 19 May 2008 1:34:29 pm

You have to create a subtree corresponding to your 2nd website.
For example, you will have:

Home (folder)
- 1st website homepage
-- page 1
-- page 2
- 2nd website homepage
-- page 3

Monday 19 May 2008 2:25:43 pm

After create a second subtree likeNicolas wrote, you have to modify the site.ini of each siteaccess.

For your first website :

[SiteSettings]
IndexPage=/content/view/full/( 1st website homepage node id )

For your second website :

[SiteSettings]
IndexPage=/content/view/full/( 2nd website homepage node id )

You can use the variable PathPrefix of the SiteAccessSettings section.

Friday 30 May 2008 5:18:19 pm

Hii!

How can I create another database to site2?
How can I configure site.ini to acess another database?

Thanks!

Sunday 01 June 2008 9:36:58 am

By moving database settings from site wide settings in settings/override/site.ini* to each of your siteaccess specific settings in settings/siteaccess/*/site.ini*

EDIT: Remember to use different var folders for siteaccesses that use different db, this is controlled by another site.ini setting called [FileSettings]VarDir

Modified on Monday 02 June 2008 12:26:39 pm by André R

Friday 05 September 2008 5:37:03 pm

Notice that if you're using different databases, you won't have to use IndexPage setting due to the fact that each content tree will be in his own database.

You'll also have to make an admin siteaccess for each one.

Modified on Friday 05 September 2008 5:37:46 pm by Charles-Edouard Coste

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from