This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » rc2 login weirdness
expandshrink

rc2 login weirdness

rc2 login weirdness

Tuesday 11 February 2003 12:22:21 pm - 9 replies

Im having a login problem with rc2 with a site im building.

I've created a few users that can read and add content to the site, and when i login to the user site via the usual action={"/user/login/"|ezurl}, i find that in addition to being logged in to the user site that user has also been logged into the admin site, replacing the admin user. i then have to relogin the admin user...

Im not sure if this is a setup problem (site.ini.php). Im using ports to distinguish the admin/user site.

Has anyone else seen this?

Thanks

Paul

Tuesday 11 February 2003 7:19:00 pm

Again, following my own mail up...

From what i've seen today both admin and user seem to be sharing the same $current_user variable. Change it on site and it changes on the site and vice versa.

It does look as if something has went wrong in the setup. However, im a bit stumped as to how to fix this. When i goto my admin site, 192.168.1.11:1141 for example, and 192.168.1.11:1140 for the user site, shouldn't they be running in different sessions?

Any help would be appreciated.

Paul

Wednesday 12 February 2003 1:35:57 am

> Again, following my own mail up...
>
> From what i've seen today both admin and user seem to be
> sharing the same $current_user variable. Change it on site
> and it changes on the site and vice versa.
>
> It does look as if something has went wrong in the setup.
> However, im a bit stumped as to how to fix this. When i goto
> my admin site, 192.168.1.11:1141 for example, and
> 192.168.1.11:1140 for the user site, shouldn't they be
> running in different sessions?
>
> Any help would be appreciated.
>
> Paul

I am experiensing something quite like what you're describing om my testingsite: www.bredbandavisen.no (english). Somehow visitors are required to logon to the content module of my user site even afte logon is set to false in [site access]... Anyone got a good anwer here?

Wednesday 12 February 2003 10:24:01 am

With rc2 you need to given your anonymous user explicit rights to login. Go to the roles section and add to your anonymous user the line: 'User Login *'

Hope this helps.

Paul

Wednesday 12 February 2003 11:06:11 am

> > Again, following my own mail up...
> >
> > From what i've seen today both admin and user seem to be
> > sharing the same $current_user variable. Change it on
> site
> > and it changes on the site and vice versa.
> >
> > It does look as if something has went wrong in the
> setup.
> > However, im a bit stumped as to how to fix this. When i
> goto
> > my admin site, 192.168.1.11:1141 for example, and
> > 192.168.1.11:1140 for the user site, shouldn't they be
> > running in different sessions?
> >
> > Any help would be appreciated.
> >
> > Paul
>
>
> I am experiensing something quite like what you're
> describing om my testingsite: www.bredbandavisen.no
> (english). Somehow visitors are required to logon to the
> content module of my user site even afte logon is set to
> false in [site access]... Anyone got a good anwer here?

I face the same problem: user site requires login of anonymous visitors even after you set user-login required=false. The problem was not present in rc1. After thorough examination of ini.parameters, I am convinced there is a bug. I shall report this.

Wednesday 12 February 2003 12:39:32 pm

I had this... try http://developer.ez.no/forum/message/14361/ as anon users need to have login rights now.

> > I am experiensing something quite like what you're
> > describing om my testingsite: www.bredbandavisen.no
> > (english). Somehow visitors are required to logon to the
> > content module of my user site even afte logon is set to
> > false in [site access]... Anyone got a good anwer here?
>
> I face the same problem: user site requires login of
> anonymous visitors even after you set user-login
> required=false. The problem was not present in rc1. After
> thorough examination of ini.parameters, I am convinced there
> is a bug. I shall report this.

Sunday 16 February 2003 12:56:22 pm

> With rc2 you need to given your anonymous user explicit
> rights to login. Go to the roles section and add to your
> anonymous user the line: 'User Login *'
>
> Hope this helps.
>
> Paul

There is still a way to restore the old behaviour of account-less sessions for anonymous users: Open your index.php-file and alter the hard-wired settings for the $Site Basics - array there:
Switch the following two parameters from "true" to "false":

$userObjectRequired = true; (Line 42 - index.php)
$sessionRequired = true; (Line 43 - index.php)

Monday 17 February 2003 4:34:17 pm

> Im having a login problem with rc2 with a site im building.
>
>
> I've created a few users that can read and add content to
> the site, and when i login to the user site via the usual
> action={"/user/login/"|ezurl}, i find that in addition to
> being logged in to the user site that user has also been
> logged into the admin site, replacing the admin user. i then
> have to relogin the admin user...
>
> Im not sure if this is a setup problem (site.ini.php). Im
> using ports to distinguish the admin/user site.
>
> Has anyone else seen this?

Try using two different browsers, one for the admin site and one for the user. Does this solve the problem?

Monday 17 February 2003 5:32:26 pm

> Try using two different browsers, one for the admin site and
> one for the user. Does this solve the problem?

This does stop the problem from occuring. If i use mozilla and konqueror, say, I can log in seperate users at the same time.

Does this suggest that the port number is somehow being ignored when a session is assigned to a user? Im not very familiar with how a session is put together for a user...

Paul

Tuesday 18 February 2003 2:38:57 pm

> > Try using two different browsers, one for the admin site
> and
> > one for the user. Does this solve the problem?
>
> This does stop the problem from occuring. If i use mozilla
> and konqueror, say, I can log in seperate users at the same
> time.
>
> Does this suggest that the port number is somehow being
> ignored when a session is assigned to a user? Im not very
> familiar with how a session is put together for a user...

Yes the port number is not used, also some browser have problems differentiating between admin and user hostnames. We will have to do some more research to figure out how to get around this problem.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from