eZ Community » Forums » Install & configuration » Redirect 301 issue
expandshrink

Redirect 301 issue

Redirect 301 issue

Friday 31 May 2013 11:37:26 am - 5 replies

Hey everyone!

I am trying to redirect some old links to new ones using .htaccess. But i cant make it happen. I am using this code:

Redirect 301 /old http://www.mysite.com/test/new

Anyone got solution?

Thanks in advance

Friday 31 May 2013 11:58:05 am

Hi, 

An alternative is to use the built-in wildcard redirection feature, within eZ Publish, under Setup > URL Wildcards.

But within the .htaccess file, you could try the following:

RewriteRule ^/old http://www.mysite.com/test/new [L,R=301] 

Let us know,
Cheers, 

Friday 31 May 2013 12:36:47 pm

Hey Nicolas,

Thanks for fast reply!

I already try second code for .htaccess but its not working.

Also now tried with URL Wildcards but still i got no redirecting. Really don't know what is problem?

Friday 31 May 2013 4:05:07 pm

Is the rewrite module enabled in Apache?

Do you get errors when reloading the apache configuration (normally present in the command output)?

Let us know,
Cheers, 

Saturday 01 June 2013 8:18:12 am

The reply has been removed because of violation of forum rules.

Wednesday 05 June 2013 8:40:17 am

@Nicolas

Yes, rewrite module is enabled in apache. And when i restart apache i got no problem, everything works fine.

I am trying to set up this for 1week and i cant resolve this one. I am really desperate. I try everything that i found on forum....

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from