This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Setup wizard unable to complete the...
expandshrink

Setup wizard unable to complete the site creation on localhost

Setup wizard unable to complete the site creation on localhost

Friday 30 September 2011 12:00:08 pm - 14 replies

Hi,

How can I fix this problem ?

 

  • EZSW-004 Failed inserting data to mysql
    Table 'ezapprove_items' already exists
  • EZSW-040 Failed to initialize site package 'ezflow_site'

I'm on ezP 4.2 to test.

Regards,

BPP.

  • EZSW-004 Failed inserting data to mysql
    Table 'ezapprove_items' already exists
  • EZSW-040 Failed to initialize site package 'ezflow_site'

Friday 30 September 2011 12:10:06 pm

and now :

Fatal error: A database transaction in eZ Publish failed.
The current execution was stopped to prevent further problems.
 You should contact the System Administrator of this site with the information on this page.
 The current transaction ID is TRANSID-a22b1014ca3986a5c3bd57e4ca39778b and has been logged.
 Please include the transaction ID and the current URL when contacting the system administrator.

WTF ?!!! Finetune is however ok :'(

Modified on Friday 30 September 2011 12:15:47 pm by Pascal Pineur

Friday 30 September 2011 12:45:35 pm

It looks like your db was not empty - possibly a failed previous install attempt. Just drop it and recreate it, and start setup wizard from scratch

Monday 03 October 2011 3:10:27 am

I got the "unable to complete" error today too, but I think it is related to the hosting company and/or server I'm installing on.

Sunday 06 November 2011 8:53:54 am

I'm on ezP 4.3 and have also got:

  • EZSW-004 Failed inserting data to mysql
    Table 'ezapprove_items' already exists
  • EZSW-040 Failed to initialize site package 'ezflow_site'

Will reinstall now...

Found that 'ezflow_site' is on the download list (http://packages.ez.no/ezpublish/4.3/4.3.0/), but not mentioned in the import list.

I also removed all tables from phpMyAdmin, but eZ Publish recreate them and the same error message turn up...

 

Any one know how to proceed?  I know I'm only on economy hosting at GoDaddy, so I'm not expecting miracles...

Modified on Sunday 06 November 2011 10:20:19 am by Jonas Backelin

Saturday 26 November 2011 3:54:16 pm

I'm on eZP Community Project 2011.10 and I have also got the same problem when I click "next" at the site registration part at the end of installation:

:Fatal error: Class 'ezidentifiertype' not found in /var/www/localhost/htdocs/ezpublish/kernel/classes/ezdatatype.php on line 172
Fatal error: eZ Publish did not finish its request

If I go back and press the next button again:

    EZSW-004 Failed inserting data to mysql
    Table 'ezapprove_items' already exists
    EZSW-040 Failed to initialize site package 'ezflow_site'

If I drop all tables from phpMyAdmin, then the first Fatal error comes again...

Some info:
PHP info: Php-5.4.0
Web server info: Apache-2.2.21
Database info: MariaDB-5.3.1

php.ini
max_execution_time = 180
memory_limit = 256M
max_input_time = 90

Any idea?

Modified on Saturday 26 November 2011 4:00:27 pm by Keen Blade

Saturday 26 November 2011 4:40:18 pm

Hello Keen,

You need to run this command (to regenerate autoloads required by eZ Publish)

cd /path/to/ezpublish; php ./bin/php/ezpgenerateautoloads.php -v; php ./bin/php/ezpgenerateautoloads.php -v -e

Then you need to run this command (to clear all caches, just in case)

cd /path/to/ezpublish; php ./bin/php/ezcache.php --clear-all --purge

Then drop all your existing tables and re-run the setup wizard.

 

I hope this helps ...

 

Cheers,

Heath

Saturday 26 November 2011 5:06:01 pm

Hi, Heath. I tried your commands, but nothing changed. The first command has run fine. The second command wanted me to add "--allow-root-user" paramater. I added it and it said

"An unexpected error has occurred. Please contact the webmaster."

Also it outputs lots of this, although date.timezone is set in php.ini

Warning: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /var/www/localhost/htdocs/ezpublish/lib/ezutils/classes/ezdebug.php on line 893
PHP Warning:  strftime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Helsinki' for 'EET/2.0/no DST' instead in /var/www/localhost/htdocs/ezpublish/lib/ezutils/classes/ezdebug.php on line 893

I enabled debug and here is the output:

Fatal error: Class 'ezidentifiertype' not found in /var/www/localhost/htdocs/ezpublish/kernel/classes/ezdatatype.php on line 172
 Fatal error: eZ Publish did not finish its request

The execution of eZ Publish was abruptly ended, the debug output is present below.

eZ debug

Timing: Nov 26 2011 17:54:02
Script start
Timing: Nov 26 2011 17:54:02
Module start 'setup'

Timing points:

Checkpoint

Elapsed

Rel. Elapsed

Memory

Rel. Memory

Script start 0.0000 sec 0.0263 sec 1,747.3672 KB 1,074.5313 KB
Module start 'setup' 0.0263 sec   2,821.8984 KB  
Total runtime: 29.9063 sec
Peak memory usage: 15,241.3047 KB

Time accumulators:

 Accumulator

 Elapsed

 Percent

 Count

 Average

ini_load        
Load cache 0.0131 sec 0.0438% 14 0.0009 sec
Check MTime 0.0007 sec 0.0024% 11 0.0001 sec
Find INI Files 0.0003 sec 0.0011% 3 0.0001 sec
Parse 0.0044 sec 0.0149% 2 0.0022 sec
Save Cache 0.0015 sec 0.0052% 2 0.0008 sec
TS translator        
TS init 0.0120 sec 0.0402% 2 0.0060 sec
TS cache load 0.0025 sec 0.0082% 2 0.0012 sec
TS context load 0.0014 sec 0.0047% 2 0.0007 sec
Mysql Total        
Mysqli_queries 29.6222 sec 98.9755% 2177 0.0136 sec
Looping result 0.0000 sec 0.0001% 1 0.0000 sec
General        
String conversion 0.0000 sec 0.0001% 4 0.0000 sec
dbfile 0.0000 sec 0.0000% 1 0.0000 sec
INI string conversion 0.0000 sec 0.0001% 2 0.0000 sec
Total script time: 29.9288 sec

Modified on Saturday 26 November 2011 5:10:03 pm by Keen Blade

Sunday 27 November 2011 4:27:57 am

Hello Keen,

I would enable all php and ez debugging options at this point.

php.ini display_errors=On

Also as the debug output says, you need to configure your php.ini:date.timezone setting.

Alternatively you might be able to do this using an eZ Publish config.php file (I've done this myself before).

After you have done these things then you should 're-peat' my command line instructions as those are required to complete successfully in order for eZ Publish setup wizard to complete successfully.

A final note the last message you shared about the missing class, that is because the commands I shared were not run successfully. Until you can run these commands successfully you will not be able to setup eZ Publish (they are that important).

 

I hope this helps ...

 

Cheers,

Heath

Monday 28 November 2011 10:42:05 pm

Heath, thank you very much for your assistance.

Hello Keen,

I would enable all php and ez debugging options at this point.

php.ini display_errors=On

It is already set on.

Also as the debug output says, you need to configure your php.ini:date.timezone setting.

Done, now timezone warning gone.

After you have done these things then you should 're-peat' my command line instructions as those are required to complete successfully in order for eZ Publish setup wizard to complete successfully.

I repeated the commands. First command runs fine, again. The second command, I found out --purge gives error. If I run only "php ./bin/php/ezcache.php --clear-all --allow-root-user" it works, but install stuck at the same as before. I added "-d" to your second commad and it gives this error:

  • An unexpected error has occurred. Please contact the webmaster.
  • Unable to connect to the database server 'localhost'
  • Error #1045: Access denied for user 'root'@'localhost' (using password: NO) in /var/www/localhost/htdocs/ezpublish/lib/ezdb/classes/ezmysqlidb.php on line 131

/ezpublish/var/log/error.log:

[ Nov 28 2011 23:51:34 ] [] eZCache::clearItem:
No path specified for cache item 'Class identifier cache', can not clear cache.
[ Nov 28 2011 23:51:34 ] [] eZCache::clearItem:
No path specified for cache item 'Sort key cache', can not clear cache.
[ Nov 28 2011 23:51:34 ] [] eZMySQLiDB:
Connection error: Couldn't connect to database server. Please try again later or inform the system administrator.
Access denied for user 'root'@'localhost' (using password: NO)
[ Nov 28 2011 23:51:34 ] Unexpected error, the message was : Unable to connect to the database server 'localhost'
Error #1045: Access denied for user 'root'@'localhost' (using password: NO) in /var/www/localhost/htdocs/ezpublish/lib/ezdb/classes/ezmysqlidb.php on line 131

So it seems php needs to know my root mysql passwd. How to provide it to php?

Edit: I put the mysql passwd databasename in site.ini.append.php. Then your both commands run fine. But second command gives this at error.log:

[ Nov 29 2011 00:17:38 ] [] eZCache::clearItem:
No path specified for cache item 'Class identifier cache', can not clear cache.
[ Nov 29 2011 00:17:38 ] [] eZCache::clearItem:
No path specified for cache item 'Sort key cache', can not clear cache.
[ Nov 29 2011 00:17:38 ] [] eZCache::clearItem:
No path specified for cache item 'Content tree menu (browser cache)', can not clear cache.
[ Nov 29 2011 00:17:38 ] [] eZCache::clearItem:
No path specified for cache item 'State limitations cache', can not clear cache.
[ Nov 29 2011 00:17:38 ] [] eZCache::clearItem:
No path specified for cache item 'Design base cache', can not clear cache.
[ Nov 29 2011 00:17:38 ] [] eZCache::clearItem:
No path specified for cache item 'Active extensions cache', can not clear cache.

And the the final eror is still almost the same at the end of installation:

Fatal error: Class 'ezidentifiertype' not found in /var/www/localhost/htdocs/ezpublish/kernel/classes/ezdatatype.php on line 172
 Fatal error: eZ Publish did not finish its request

The execution of eZ Publish was abruptly ended, the debug output is present below.

eZ debug

Timing: Nov 29 2011 00:20:27
Script start
Timing: Nov 29 2011 00:20:27
Module start 'setup'

Timing points:

Checkpoint

Elapsed

Rel. Elapsed

Memory

Rel. Memory

Script start 0.0000 sec 0.0248 sec 1,747.3672 KB 1,074.5313 KB
Module start 'setup' 0.0248 sec   2,821.8984 KB  
Total runtime: 33.3327 sec
Peak memory usage: 15,248.5859 KB

Time accumulators:

 Accumulator

 Elapsed

 Percent

 Count

 Average

ini_load        
Load cache 0.0212 sec 0.0636% 14 0.0015 sec
Check MTime 0.0006 sec 0.0019% 11 0.0001 sec
Find INI Files 0.0005 sec 0.0015% 3 0.0002 sec
Parse 0.0104 sec 0.0312% 3 0.0035 sec
Save Cache 0.0031 sec 0.0092% 3 0.0010 sec
TS translator        
TS init 0.0133 sec 0.0398% 2 0.0066 sec
TS cache load 0.0036 sec 0.0108% 2 0.0018 sec
TS context load 0.0025 sec 0.0076% 2 0.0013 sec
Mysql Total        
Mysqli_queries 33.0119 sec 98.9696% 2177 0.0152 sec
Looping result 0.0000 sec 0.0001% 1 0.0000 sec
General        
String conversion 0.0001 sec 0.0002% 6 0.0000 sec
dbfile 0.0000 sec 0.0001% 1 0.0000 sec
INI string conversion 0.0001 sec 0.0003% 4 0.0000 sec
Total script time: 33.3556 sec

Also starting from scratch with the clean eP tarball, it stucks at the same thing.

Should I worry if installing eP to the real hosting service will be more difficult, because I won't have control over it like on my local system?

Modified on Tuesday 29 November 2011 12:02:57 am by Keen Blade

Tuesday 29 November 2011 4:59:50 am

Hello Keen,

Sorry my reply tonight is very brief as I have run out of time for work tonight (always too much to do, you understand)

 

First the main problem remains that your eZ Publish autoloads are not being properly created (when you run the first command).

I would drop everything and focus on this, I would also suggest you login to freenode.net IRC #ezpublish and have someone help you through these configuration problems in a more real time way, it's loads of fun and often you get solutions more quickly. Just a suggestion I don't mind continuing to help you here in parallel.

eZ Publish does not run on most basic forms of hosting like shared hosting and a number of low resource / low end vm systems, plain and simple.

I tell customers eZ Publish requires dedicated hosting (for a long list of reasons). Though I've seen and worked with folks using eZ with things like GoDaddy hosting (and i'm really not recommending that or them btw, just commenting on something I saw). Get decent linux hosting that you control, it's worth it when you have to use eZ Publish.

 

Returning to the problem locally at hand. You need to continue to debug the autoload generation execution as you have to get this right first and foremost. Run the the autoload generation command with verbose option enabled, you should get a the output of the autoloads written to file, this should have content, it should not produce no output. You mention no output so that strikes me as a concern ...

I would ignore for now the problems encountered by the second command for the moment and focus on the autoloads as key.

 

I hope this helps ...

 

Cheers,

Heath

Friday 02 December 2011 9:22:07 pm

Heath, thanks for giving your time for this. Today I tried eZP Community Project 2011.11 with the same results.

First the main problem remains that your eZ Publish autoloads are not being properly created (when you run the first command)...

Run the the autoload generation command with verbose option enabled, you should get a the output of the autoloads written to file, this should have content, it should not produce no output. You mention no output so that strikes me as a concern ...

The first command did not give an error, but I am not sure if it is working right, since it outputs something  between <?php ?>

Here is the output:

For the second command, there is no error, after I provide "User, Dabase and Password" at the section [DatabaseSettings] in site.ini.append.php. Herrrrrrrrrre is the output:

Purging All cache:
Content view cache, Global INI cache, INI cache, Codepage cache, Class identifier cache, Sort key cache, URL alias cache, Character transformation cache, Image alias, Template cache, Template block cache, Template override cache, Text to image cache, RSS cache, User info cache, Content tree menu (browser cache), State limitations cache, Design base cache, Active extensions cache, TS Translation cache, REST Application cache, REST Routes memory cache
#################################### DEBUG ####################################
Notice: (eZMySQLiDB::query(0.000 ms) query number per page:0)
SELECT id, serialized_name_list, serialized_description_list, version, contentclass_id, identifier, placement,       is_searchable, is_required, can_translate, is_information_collector, data_type_string, data_int1, data_int2,       data_int3, data_int4, data_float1, data_float2, data_float3, data_float4, data_text1,       data_text2, data_text3, data_text4, data_text5, serialized_data_text, category
                    FROM   ezcontentclass_attribute WHERE  data_type_string='ezimage' AND version='0' ORDER BY placement ASC
Notice: (eZMySQLiDB::query(0.000 ms) query number per page:1)
SELECT *
                FROM ezcontentobject_tree
                WHERE node_id = 1
Total script time: 10.1552 sec

 

Modified on Friday 02 December 2011 10:03:43 pm by Keen Blade

Friday 02 December 2011 9:41:27 pm

Hello Keen,

 

#1 - The command output is valid and appears (offhand) to be 100% correct. Good job! A warning first, I think this means your autoloads have been generated. you should validate this by inspecting the files written out to disk correctly as well, re: 'autoloads/' and 'var/autoloads' (pastebin if your uncertain).

PS thank you very much for the pastebin! That was very smart of you to share happy.gif Emoticon

And I think it was even smarter for you to try the latest build recently release 2011.11 happy.gif Emoticon

Your getting sharper. It will only be a matter of time before you surpass us all in your eZp knowledge happy.gif Emoticon

 

#2 - I'm not certain offhand (sorry away from ezp install to test this right now) but I think you can ignore #2 again as well (if in doubt remove all files manually from var/cache/* and var/ezwebin_site/cache*, which will hurt nothing)

 

#3 - I think it's time for you to drop your db (get rid of all the existing tables and data or you'll run into other problems later in the setup process ... fyi). Remember to re-create your database as a utf8 database or you will also run into problems.

#4 - Now then, it's time to try the setup wizard again. Watch for errors in the ezp logs, apache web server logs, if any php error logs exist check those too and watch for displayed errors in page.

 

I hope this helps ...

Cheers,

Heath

Modified on Friday 02 December 2011 9:42:09 pm by // Heath

Friday 15 February 2013 12:27:01 pm

Hi,

I also had the same problem today, and followed some of Heat's instructions and succeeded to install EzPublish on a VPS.

So, here's what I did. Hope it can help someone else.

  1. Cleared the the database previously installed: dropped all the database tables.
  2. Cleared the cache manually in var/cache. Couldn't manage to have ssh access to the server, so couldn't also regenerate the autoload arrays in the command line that Hath advised.
  3. Altered php.ini memory limit from 64M to 120M
  4. Altered the max_execution_time to 3000. As my server was taking too long to respond, I thought that altering this parameter would help.

 

Friday 15 February 2013 3:15:26 pm

Quote from Fátima Chapri :

Hi,

I also had the same problem today, and followed some of Heat's instructions and succeeded to install EzPublish on a VPS.

So, here's what I did. Hope it can help someone else.

  1. Cleared the the database previously installed: dropped all the database tables.
  2. Cleared the cache manually in var/cache. Couldn't manage to have ssh access to the server, so couldn't also regenerate the autoload arrays in the command line that Hath advised.
  3. Altered php.ini memory limit from 64M to 120M
  4. Altered the max_execution_time to 3000. As my server was taking too long to respond, I thought that altering this parameter would help.

 

Thanks for sharing!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from