This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » SourceGuardian STRANGE issue
expandshrink

SourceGuardian STRANGE issue

SourceGuardian STRANGE issue

Friday 01 April 2011 9:05:15 pm - 2 replies

Hi. I'm having this very strange issue here. Im having eerro logs since last night about SourceGuardian:

[01-Apr-2011 03:24:01] PHP Warning: Module 'SourceGuardian' already loaded in Unknown on line 0
[01-Apr-2011 03:24:01] PHP Warning: Module 'SourceGuardian' already loaded in Unknown on line 0

The error log appears every minute... twice. Only in the EZ Root directory...

php.ini is celan aobut this, in fact, the server has no other app in it.

ANYBODY knows what this could be???? Are there any components, extensions, add-ins... that could be using?

The ONLY estensions I have installed apart from EZFLow and the obvious ones included in EZ Publish 4.4 are:

EzFind

EZMultiupload

EZStyleEditor

EZSurvey

ggxmlview

googlesitemapgenerator

recpatcha

I Thought all of these were open soruce but now Im not sure!!

This log is getting pretty big very fast. HELP!

Friday 01 April 2011 9:21:46 pm

Hi Luis,

All of these extensions are definitely open-source in their standard version. If you installed the versions shipped with the standard eZ Publish package, this error can not stem from those. eZ Publish's kernel also is open-source, 100%.

You may want to check your php.ini configuration file and look for the SourceGuardian loading line. More info can be found here : http://www.sourceguardian.com/protect_php_scripts.html

Cheers,

Tuesday 05 April 2011 8:39:45 pm

Hi Luis,

All of these extensions are definitely open-source in their standard version. If you installed the versions shipped with the standard eZ Publish package, this error can not stem from those. eZ Publish's kernel also is open-source, 100%.

You may want to check your php.ini configuration file and look for the SourceGuardian loading line. More info can be found here : http://www.sourceguardian.com/protect_php_scripts.html

Cheers,

Nicolas!!

I solved the problem... even though the error_log ONLY appeared in the EZ Publish folder... the problem was actually WHM/cPanel. There is a bug in the PHP configuration wizard who duplicates extension load. Removing the extra string solved the problem.

Still dont understand why if we have other Apps in the hosting site no other reported this error...

Thanks!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from