This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit

eZ Community » Forums » Install & configuration » SSL still on for section removed from...

SSL still on for section removed from SSLSubtrees

SSL still on for section removed from SSLSubtrees

Thursday 02 April 2015 10:22:55 pm - 4 replies

I've run into an odd issue with SSL. I enabled it using the SSLSubtrees in site.ini.append.php like so:


It turned on and worked as expected.

However, when I removed the "products" section (saved, cleared cache, etc.), it continued to redirect to https for everything in the products section.


Is there something else that needs to be done? If I set SSLZones to 'disabled' it all turns off, but I'm unable to turn off the just one section.

I believe I'm running eZ Publish 4.6


Modified on Thursday 02 April 2015 10:23:24 pm by David Schafer

Friday 03 April 2015 1:31:21 am

Hello David,

Welcome to the eZ Community!

You should search you cache directories for the ssl zone cache file, 'ssl_zones_cache.php',

Here is a simple example: find . -name "*ssl_zones_cache.php"

Then you can review it to see if you settings changes are contained within and or you can remove it.

Otherwise in general I would suggest clearing all caches manually.

If review of the ssl zone cache file does not help as it should ...

You could also enable settings/override/debug.ini.append.php [GeneralCondition] kernel-ssl-zone=enabled

And enable settings/override/site.ini.append.php DebugOutput and DebugRedirection. Then clear all caches.

When you reload the page you should be prompted to confirm the redirection action before it actually does the redirection.

Remember to navigate to the page in question using http when testing.

You can also see in the debug output or the debug.log the kernel-ssl-zone debug log entries related to your page load test.

EDIT: It seems that this bug may still remain in the community edition:

EDIT2: I could not reproduce the but with eZ Publish Enterprise 5.1

EDIT3: It seems like a bug (possibly similar to the one above, unknown because of lack of proper details) was solved in the 2013.1 tag/build,

I hope this helps!


Modified on Friday 03 April 2015 3:59:00 am by // Heath

Friday 03 April 2015 2:39:57 pm


What an incredibly helpful answer. The section I needed to remove was, in fact, inside of that "ssl_zones_cache.php" file and I removed it. Worked perfectly. This was a real headache for me.

I figured there was a file like this somewhere. I just had no idea where to look.


Saturday 04 April 2015 12:25:08 am

If you're in dev, a good old rm -rf var/cache/* var/*/cache/* usually does the trick. Don't do it on production please blunk.gif Emoticon

Saturday 04 April 2015 8:18:59 pm

Hello David,

Thank you for your praise. You made my day happy.gif Emoticon

I'm happy I was able to help you solve the problem.

Can you login to and then click the checkbox at the top of your original post near the title? It is the box with the checkbox inside. It turns green when you have clicked it correctly.

Doing this indicates your question has been solved.

Thanks again for your continued support!

Take it eZ!



You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from