This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » Sub items not showing
expandshrink

Sub items not showing

Sub items not showing

Monday 28 March 2011 1:21:52 pm - 10 replies

It's late, and maybe I'm missing something... but.

I have a brand new install of ezwebin with demo content (4.5.0 beta1). I go into the admin interface and select 'company/news'. The bottom of the News [Folder] area says that I have 5 subitems, but I can't see them.

This page

http://doc.ez.no/eZ-Publish/User-...l/4.4/Daily-tasks/Managing-sub-items

Says something about a 'table options' dialogue, but I can't see anything. How do I display these items?

Monday 28 March 2011 2:15:18 pm

Hi,

Check if it is related to http://share.ez.no/forums/install...ror-message-after-new-install-of-4.4, bug fixed in eZ Publish 4.5 release.

Monday 28 March 2011 9:04:12 pm

It's possible I suppose. There's a big slab of js there instead of any html. Whichever though, This is a fresh install of 4.5 viewed with Firefox 3.6 and Chrome 10.0.648.204.

The item view is fine in the front end, just not in the admin interface.

It certainly wouldn't be giving first time users or potential customers a good first impression of eZ.

Modified on Monday 28 March 2011 9:05:49 pm by paul bolger

Tuesday 29 March 2011 4:35:39 am

It might be related to installations with more than one language. I saw it on eZ 4.2, with eZwebin installed and there were en-US and en-GB classes. I have an eZ 4.4 installation, with just en-US, no eZwebin, and it looks okay.

Tuesday 29 March 2011 9:11:55 am

Are you sure all your javascript files are loading? I've seen this happen with javascript not loading.

Tuesday 29 March 2011 9:27:22 am

It might be related to installations with more than one language. I saw it on eZ 4.2, with eZwebin installed and there were en-US and en-GB classes. I have an eZ 4.4 installation, with just en-US, no eZwebin, and it looks okay.

Hi Betsy, nice to hear from you! I don't think that's the problem though: I've tried having different language/locations active before and this time I decided to make life easy for myself and just use en-GB. Having the right flag icon isn't worth the pain.

paul b

Tuesday 29 March 2011 9:33:59 am

Are you sure all your javascript files are loading? I've seen this happen with javascript not loading.

Hi Steven,

I think you may be right. I'm getting a kernel (20) error on

http://mysite/extension/ezjscore/...i/2.8.1/build/utilities/utilities.js

So, a problem with my rewrite rules maybe? I must admit I've been cutting and pasting the same block for a while now.

<VirtualHost *:80>
<IfModule mod_rewrite.c>
RewriteEngine On
Rewriterule ^/var/storage/.* - [L]
Rewriterule ^/var/[^/]+/storage/.* - [L]
RewriteRule ^/var/cache/texttoimage/.* - [L]
RewriteRule ^/var/[^/]+/cache/texttoimage/.* - [L]
Rewriterule ^/design/[^/]+/(stylesheets|images|javascript)/.* - [L]
Rewriterule ^/share/icons/.* - [L]
Rewriterule ^/extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts?)/.* - [L]
Rewriterule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
RewriteRule ^/favicon\.ico - [L]
RewriteRule ^/robots\.txt - [L]
RewriteRule ^/var/[^/]+/cache/public/.* - [L]
# Uncomment the following lines when using popup style debug.
# RewriteRule ^/var/cache/debug\.html.* - [L]
# RewriteRule ^/var/[^/]+/cache/debug\.html.* - [L]
RewriteRule .* /index.php
RewriteCond %{HTTP_HOST} ^webdav\..*
RewriteRule ^(.*) /webdav.php [L]
</IfModule>
ServerName mysite
ServerAlias www.mysite
ServerAlias admin.mysite
ServerAlias www.admin.mysite
DocumentRoot /www/ezpublish/sites/mysite
</VirtualHost>

Odd that it'd only affect the admin siteaccess though.

Modified on Tuesday 29 March 2011 12:32:01 pm by paul bolger

Tuesday 29 March 2011 12:38:45 pm

Hi Paul,

You should replace:

Rewriterule ^/extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts?)/.* - [L]

by:

Rewriterule ^/extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts|lib?)/.* - [L]

Wednesday 30 March 2011 12:07:32 pm

Hi Paul,

You should replace:

Rewriterule ^/extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts?)/.* - [L]

by:

Rewriterule ^/extension/[^/]+/design/[^/]+/(stylesheets|images|javascripts|lib?)/.* - [L]

Thanks Jan-Luc. That still doesn't seem to fix it though.

I've also tried removing all the rewrite rules and using the index.php URLs, but that doesn't work either.

Thursday 31 March 2011 12:53:45 am

I've taken a look at my two sites running 4.4 and they are working just fine, with the original rewrite rules. This does seem to be a 4.5 issue.

(edit) strike that, it was a rewrite issue, and it's sorted now.

Modified on Sunday 03 April 2011 4:31:38 am by paul bolger

Thursday 06 December 2012 10:57:30 am

I have the same problem using ez publish 2012.6. Just activated the admin2 interface and the subitems doesn't show up. I use these rewrite rules in apache:

http://doc.ez.no/eZ-Publish/Techn.../5.x/Installation/Virtual-host-setup

<span class="line">RewriteEngine On</span><span class="line">       </span>
<span class="line"># Uncomment in FastCGI mode, to get basic auth working.</span><span class="line">       </span>
<span class="line">#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]</span><span class="line">      </span>
<span class="line"> # v1 rest API is on Legacy</span><span class="line">       RewriteRule ^/api/[^/]+/v1/ /index_rest.php [L]</span><span class="line"> </span><span class="line">       </span>
<span class="line"> # If using cluster, uncomment the following two lines:</span><span class="line">        </span>
<span class="line">#RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* /index_cluster.php [L]</span><span class="line">        </span>
<span class="line">#RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* /index_cluster.php [L]</span><span class="line"> </span><span class="line">        </span>
<span class="line">RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]</span><span class="line">        </span>
<span class="line">RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* - [L]</span><span class="line">        </span>
<span class="line">RewriteRule ^/design/[^/]+/(stylesheets|images|javascript|fonts)/.* - [L]</span><span class="line">        </span>
<span class="line">RewriteRule ^/share/icons/.* - [L]</span><span class="line">        </span>
<span class="line">RewriteRule ^/extension/[^/]+/design/[^/]+/(stylesheets|flash|images|lib|javascripts?)/.* - [L]</span><span class="line">       </span>
<span class="line"> RewriteRule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]</span><span class="line">       </span>
<span class="line"> RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]</span><span class="line">        </span>
<span class="line">RewriteRule ^/var/storage/packages/.* - [L]</span><span class="line"> </span><span class="line">        </span>
<span class="line"># Makes it possible to place your favicon at the root of your</span><span class="line">        </span>
<span class="line"># eZ Publish instance. It will then be served directly.</span><span class="line">       </span>
<span class="line"> RewriteRule ^/favicon\.ico - [L]</span><span class="line">       </span>
<span class="line"> # Uncomment the line below if you want you favicon be served</span><span class="line">       </span>
<span class="line"> # from the standard design. You can customize the path to</span><span class="line">       </span>
<span class="line"> # favicon.ico by changing /design/standard/images/favicon\.ico</span><span class="line">       </span>
<span class="line"> #RewriteRule ^/favicon\.ico /design/standard/images/favicon.ico [L]</span><span class="line">        </span>
<span class="line">RewriteRule ^/design/standard/images/favicon\.ico - [L]</span><span class="line"> </span><span class="line">        </span>
<span class="line"># Give direct access to robots.txt for use by crawlers (Google,</span><span class="line">        # Bing, Spammers..)</span><span class="line">       </span>
<span class="line">RewriteRule ^/robots\.txt - [L]</span><span class="line"> </span><span class="line">        </span>
<span class="line"># Platform for Privacy Preferences Project ( P3P ) related files</span><span class="line">       </span>
<span class="line"># for Internet Explorer</span><span class="line">        </span>
<span class="line"># More info here : http://en.wikipedia.org/wiki/P3p</span><span class="line">        </span>
<span class="line">RewriteRule ^/w3c/p3p\.xml - [L]</span><span class="line"> </span><span class="line">        </span>
<span class="line"># Uncomment the following lines when using popup style debug in legacy</span><span class="line">        </span>
<span class="line">#RewriteRule ^/var/([^/]+/)?cache/debug\.html.* - [L]</span><span class="line"> </span><span class="line">       </span>
<span class="line"> # Following rule is needed to correctly display assets from eZ Publish5 / Symfony bundles</span><span class="line">        </span>
<span class="line">RewriteRule ^/bundles/ - [L]</span><span class="line"> </span><span class="line">        </span>
<span class="line">RewriteRule .* /index.php</span>
expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from