eZ Community » Forums » Install & configuration » Translations Not Working
expandshrink

Translations Not Working

Translations Not Working

Wednesday 29 December 2010 1:26:23 pm - 7 replies

Hi Everyone!

I'm configuring trasnlations for my website, all ok but the traslated content is not showing.

I was edited a frontpage in many different languages but only default language is displayed.

My default language: por-BR

translations: eng-US, esl-ES

Regional Settings of my siteacess:

[RegionalSettings]
Locale=por-BR
ContentObjectLocale=por-BR
ShowUntranslatedObjects=disabled
SiteLanguageList[]
SiteLanguageList[]=por-BR
SiteLanguageList[]=eng-US
SiteLanguageList[]=esl-ES
TextTranslation=enabled

Help

Thanks!

Modified on Wednesday 29 December 2010 1:37:22 pm by Washington Moreira

Monday 03 January 2011 1:29:20 pm

hi, did you setup a different siteaccess for each language and changed the RegionalSettings (Locale and ContenObjectLocale) for each siteaccess to the corresponding language?

Monday 03 January 2011 2:13:31 pm

hi, did you setup a different siteaccess for each language and changed the RegionalSettings (Locale and ContenObjectLocale) for each siteaccess to the corresponding language?

Hi, i've created 3 siteacesses, each for language.

Default Language siteaccess: por

[RegionalSettings]
Locale=por-BR
ContentObjectLocale=por-BR
SiteLanguageList[]=por-BR

Optional Language siteaccess: eng

[RegionalSettings]
Locale=eng-US
ContentObjectLocale=eng-US
SiteLanguageList[]=eng-US
SiteLanguageList[]=por-BR

Optional Language siteaccess: esl

[RegionalSettings]
Locale=esl-ES
ContentObjectLocale=esl-ES
SiteLanguageList[]=esl-ES

It's good to remember that my override/site.append.ini.php doesn't have RegionalSetting set

But still not working.

Thanks

Modified on Monday 03 January 2011 2:25:22 pm by Washington Moreira

Monday 03 January 2011 2:57:50 pm

sounds good.
one thing: you have to always add all siteaccesses under SiteLanguageList[] not just the main one.
and in your override/site.ini.append.php you need:

[SiteSettings]

DefaultAccess=por
SiteList[]=por
SiteList[]=eng
SiteList[]=esl
... (your admin siteaccess)

[SiteAccessSettings]
AvailableSiteAccessList[]=por
AvailableSiteAccessList[]=eng
AvailableSiteAccessList[]=esl
... (your admin siteaccess)

Monday 03 January 2011 3:27:31 pm

sounds good.
one thing: you have to always add all siteaccesses under SiteLanguageList[] not just the main one.
and in your override/site.ini.append.php you need:

[SiteSettings]

DefaultAccess=por
SiteList[]=por
SiteList[]=eng
SiteList[]=esl
... (your admin siteaccess)

[SiteAccessSettings]
AvailableSiteAccessList[]=por
AvailableSiteAccessList[]=eng
AvailableSiteAccessList[]=esl
... (your admin siteaccess)

Ok, now i have the following configurations:

Default siteaccess: por

[RegionalSettings]
Locale=por-BR
ContentObjectLocale=por-BR
SiteLanguageList[]=por-BR
SiteLanguageList[]=eng-US
SiteLanguageList[]=esl-ES

Optional siteacess: eng

[RegionalSettings]
Locale=eng-US
ContentObjectLocale=eng-US
SiteLanguageList[]=eng-US
SiteLanguageList[]=por-BR
SiteLanguageList[]=esl-ES

Optional siteaccess: esl

[RegionalSettings]
Locale=esl-ES
ContentObjectLocale=esl-ES
SiteLanguageList[]=esl-ES
SiteLanguageList[]=por-BR
SiteLanguageList[]=eng-US

Override:

[SiteSettings]
DefaultAccess=por
SiteList[]=por
SiteList[]=eng
SiteList[]=esl
SiteList[]=nssite_admin // That's my admin siteaccess
[SiteAccessSettings]
CheckValidity=false
AvailableSiteAccessList[]=por
AvailableSiteAccessList[]=eng
AvailableSiteAccessList[]=esl
AvailableSiteAccessList[]=nssite_admin // That's my admin siteaccess
MatchOrder=uri
HostMatchMapItems[]

Anything wrong?

Monday 03 January 2011 3:37:58 pm

hmm, to my understanding this should be correct..not working?

if you want the language selector to work you need to add the language names to appear on the site:

[RegionalSettings]
TranslationSA[por]=Portugés
TranslationSA[eng]=English
TranslationSA[esl]=Español

Wednesday 26 January 2011 3:28:19 pm

hmm, to my understanding this should be correct..not working?

if you want the language selector to work you need to add the language names to appear on the site:

[RegionalSettings]
TranslationSA[por]=Portugés
TranslationSA[eng]=English
TranslationSA[esl]=Español

Hi again, sorry about the late...

Well... Still not working, i was trying lots of suggestions without any success.

Modified on Wednesday 26 January 2011 3:28:47 pm by Washington Moreira

Thursday 27 January 2011 3:19:28 pm

Finally!!!

I solved the this issue editing the site.append.ini of my extension settings. I just configured the RegionalSettings in this file and everything works fine now.

Thanks for the support.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from