eZ Community » Forums » Install & configuration » Trouble upgrading from 3.8.6 to 3.9.0
expandshrink

Trouble upgrading from 3.8.6 to 3.9.0

Trouble upgrading from 3.8.6 to 3.9.0

Friday 03 August 2007 12:54:50 am - 3 replies

Hi,

Following this doc:

http://ez.no/doc/ez_publish/upgra...upgrading_to_3_9/from_3_8_x_to_3_9_0

I'm trying to upgarde my site from 3.8.6 to 3.9.0 (and later to 3.9.2)

Once I've run the dbupdate-3.8.0-to-3.9.0.sql (I changed this script in order the new table type is innoDB -- MyISAM by default) I run this script:

/usr/bin/php update/common/scripts/3.9/updateclasstranslations.php -s accueil_paysan --language=fre-FR

but I always get this error message:

Using siteaccess 'accueil_paysan' for translation update
Updating Folder class

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 42 bytes) in /usr/local/www/ezp390/lib/ezxml/classes/ezdomdocument.php on line 271
Allowed memory size of 33554432 bytes exhausted (tried to allocate 34 bytes)

My site use only one language (fre-FR) and my php.ini contains:

max_execution_time = 600
max_input_time = 120
memory_limit = 128M

I restarted Apache (even the server) without success.

Pascal

Modified on Friday 03 August 2007 1:00:24 am by Pascal France

Friday 03 August 2007 2:34:30 am

Hi Pascal

It's difficult to work out why your php cli doesn't appear to honour the php.ini memory_limit setting without examining you system. Try adding the directive to the command line:

/usr/bin/php -dmemory_limit=128M update/common/scripts/3.9/updateclasstranslations.php -s accueil_paysan --language=fre-FR
I restarted Apache (even the server) without success.

This would only help for php run via the webserver. The cli version is independent of the webserver and running commands via the cli is like running a perl program.

Cheers
Bruce

Friday 03 August 2007 8:45:52 am

Hi Pascal,

Some Linux distros have separated php.ini files for apache and cli. e.g under Debian you'd have /etc/php4/apache2/php.ini and /etc/php4/cli/php.ini

I think that's your problem.

Cheers,
Linh

Friday 03 August 2007 9:30:08 am

Hi Bruce,

and thanks a lot for your reply which works fine.

Hi Linh,

Thanks a lot too.
You are absolutely right. I changed my cli/php.ini (on my Debian) and now all works fine without any command line option. I didn't know there is two php.ini config files.

Pascal

Modified on Friday 03 August 2007 9:56:47 am by Pascal France

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from