This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Two problems after installing
expandshrink

Two problems after installing

Two problems after installing

Saturday 21 June 2014 5:44:15 pm - 8 replies

First problem:
When I log on the root page, I get a 404 error :
http://ezpublish.mydomain.com/ => Redirrect to http://ezpublish.mydomain.com/ezsetup = Error 404
If I change to http://ezpublish.mydomain.com/index.php/ezsetup it works!
I have rename file  htacess_root in htacess in the "ezpublish_legacy" directory but it does not change anything ...
Second problem:
At the last step of the installation, I always get a 500 error ... I opened a ticket with my host but I do not understand ...
My php.ini file contains:
memory_limit = 256M
max_execution_time = 500
max_input_time = 500
everything seems ok, no problem except at the end of the installation: (

 

Any idea ? Thank so much.

Sunday 22 June 2014 5:34:32 pm

Which access mode are you using?

Host, URL, or port?

Sunday 22 June 2014 11:59:20 pm

I use mode Host :

http://ezpublish.mydomain.com/ for the website and http://admin.mydomain.com/ for administrative tasks

in my DNS, both inputs use the same folder /ezpublish/web

Wednesday 25 June 2014 3:16:33 am

It is possible the .htaccess file is not being read.

To check - put some junk text in there - the idea being to crash it.  If you do that and nothing bad happens, the .htaccess file isn't being read. 

Thursday 26 June 2014 11:52:12 pm

My .htaccess file is located in /ezpublish/ezpublish_legacy, if I modify the file with junk text for exemple, nothing changes, however, if I move this file in /ezpublish/web server displays an error 500.
I configured my DNS for the name "ezpublish.domain.tld" uses this root: /ezpublish/web. Is it correct ?
My .htaccess file is there in the right place in /ezpublish/ezpublish_legacy?

Friday 27 June 2014 12:35:59 pm

If you are working with eZP 5, document root should be /ezpublish/web and the .htaccess file must be in the same directory.

Once you remove the junk from /ezpublish/web/.htaccess, it should work.

Saturday 28 June 2014 12:43:13 am

Thank you for this information.
So I placed the file in the specified location and noticed that the server displays a 500 error ...: '(
After commenting line by line, I found the cause: the following line in the problem .htaccess file:
RewriteRule. * Index \. Php
If I put it in the comments, I have no more error 500. Strange is not it?

Saturday 28 June 2014 4:27:33 am

Do you have a RewriteEngine On?

Also - that RewriteRule should be written like so:

 RewriteRule .* index.php

Wednesday 09 July 2014 4:29:10 pm

Have you enabled mod_rewrite for apache?

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from