eZ Community » Forums » Install & configuration » Upgrade 3.8.x -> 3.9.x gives...
expandshrink

Upgrade 3.8.x -> 3.9.x gives Kernel(20) error [Solved]

Upgrade 3.8.x -> 3.9.x gives Kernel(20) error [Solved]

Friday 31 August 2007 11:50:26 pm - 5 replies

Hi,

I have tried to upgrade my site from 3.8.x to 3.9.x following the documentation "upgrading to 3.9 / from 3.8.x to 3.9.0" and have managed to run all scripts without any errors reported. After upgrading I had problems with the SiteAccess list not being populated, but fixed that after using AvailableSiteAccessList[] instead of Sitelist[].

Now, my problem occurs when I clear the site cache and I receive a Kernel (20) error, the Admin interface: Design and Setup reports a Kernel(20) error.

I have been searching the forum for a fix to this problem without any luck so a helpfull suggestion would be great.

Modified on Saturday 01 September 2007 10:33:00 am by

Saturday 01 September 2007 4:04:00 am

Hello Hans-Henry!

eZpedia says, the 'Kernel 20' error stands for the error, "Module not found".
<i>http://ezpedia.org/wiki/en/ez/kernel_error_codes</i>

I wonder if there is a problem with your host / siteaccess configuration :/

It sure seems that eZ is not configured correctly to map the url your trying to use to access the site(s) to the desired or expected configuration.

Cheers,
//kracker

<i>* Film : The Conversation ..</i>

Modified on Saturday 01 September 2007 4:25:57 am by // kracker

Saturday 01 September 2007 8:35:03 am

Thank you for your reply kracker.

Could it be an idea to do a fresh/new installation of 3.9.x and import the content from 3.8.x using package tool?

I assume that would solve the siteaccessproblem and I would also get the ezwebin extension installed.

Is my assumption correct?

Modified on Saturday 01 September 2007 8:37:03 am by

Saturday 01 September 2007 9:15:49 am

Hello Hans-Henry,

While <i>kracker</i> points out in general a more verbose description of the kernel error code's meaning. I think a more clear example would be most helpful here.

Your problem appears not to be with your eZ Publish installation in general. While you can start over from scratch, I don't think I would recommend that action at this point, that would seem like an excessive over reaction. This would take an experienced eZ Publish user like myself 15 min to solve from an ssh connection to your server.

See it is all in the SiteAccessSettings configuration!

Example of the url you might have used to accessed the site, http://admin.example.com/index.php/setup/cache

Yet if your siteaccess configuration is not properly configured. eZ might expect the url to be, http://admin.example.com/setup/cache

Which could return the kernel 20 error. As eZ would report the error as it thinks your trying to access a module name which is not recognized because ... the site is configured to interpret urls one way and your accessing it another way.

Why not first share instead your SiteAccessSettings configuration settings here in the form for further debug? Here is an example ...

File: <i>settings/override/site.ini.append.php</i>

[SiteSettings]
SiteList[]=ezwebin_site_user
SiteList[]=ezwebin_site_admin
SiteName=Example
SiteURL=www.example.com

[SiteAccessSettings]
CheckValidity=false
ForceVirtualHost=true
AvailableSiteAccessList[]=ezwebin_site_user
AvailableSiteAccessList[]=ezwebin_site_admin
MatchOrder=host
HostMatchMapItems[]=example.com;ezwebin_site_user
HostMatchMapItems[]=www.example.com;ezwebin_site_user
HostMatchMapItems[]=admin.example.com;ezwebin_site_admin

Cheers,
Heath

Modified on Saturday 01 September 2007 9:22:40 am by // Heath

Saturday 01 September 2007 10:27:07 am

Thanks Heath, your suggestion was precise and easy to grasp.
Now everything works perfectly, and this thread can be marked as [Solved].

I cannot see that these ini-changes has been mentioned in any upgrade documentation.

It's nice to see that it's possible to use eZ Publish over several years, I've used it since May 2001 and followed the upgrade path up to version 3.9.3. Looking forward to version 3.10 and version 4. Hopefully the upgrade will be less cumbersome than from version 2 to 3.

Saturday 01 September 2007 10:33:13 am

Hans-Henry,

Thank you for your kind words. We are pleased that our help was able to guide you (another long time eZ user and supporter) to a swift and simple solution. Best wishes ...

Cheers,
Heath

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from