eZ Community » Forums » Install & configuration » Upgrade eZ Publish 4.3 to latest version
expandshrink

Upgrade eZ Publish 4.3 to latest version

Upgrade eZ Publish 4.3 to latest version

Thursday 27 October 2011 2:55:00 pm - 28 replies

Hi

 

Is there any guide on how to upgrade 4.3 to the latest eZ Publish Community Project 2011.9?

 

Thanks

Dawid

Saturday 29 June 2013 3:59:02 pm

Hello,

Can we guys continue this nice upgrade thread. I need to upgrade from 2011.12 ->2013.6. What is the closest path?

Sunday 30 June 2013 11:44:48 pm

I think all you need for 2011.13 -> 2-13.6 is https://github.com/leidentech/ez-shell-tools/blob/master/convertscript.sh

Monday 01 July 2013 5:31:29 am

On my end, I tried the convertscript, I tried moving ezpublish_legacy out of the symfony 2 wrapper, but nothing works as expected. I guess I'll stay on the 4.4 until I'll find a new platform easier to use and a way to easily export contents + linked images to that platform. For now, I have neither.

Modified on Monday 01 July 2013 5:32:54 am by Hypolite Petovan

Monday 01 July 2013 8:45:51 am

Hello guys,
What I have made on weekend: I took eZ Publish v. 2012.x which was upgraded from version 4.x. (few months ago) and I took a legacy version 2013.06 (just a legacy folder). I have made a successfull ugrade to version 2013 using documentation which is avaiable on each version, for example - Upgrading from eZ Publish Community Project 2013.05 to 2013.06: http://share.ez.no/downloads/down...community-project-2013.05-to-2013.06
And I thin that everything works correctly.

Wednesday 14 August 2013 3:31:22 pm

I'm trying to migrate from 4.3 to 5.1.

I did followed the instructions of

http://doc.ez.no/eZ-Publish/Upgrading/Direct-upgrading/Direct-upgrading-to-4.7-from-4.1-4.2-4.3-4.4-and-4.5/Direct-upgrading-from-4.3-to-4.7

and then

http://doc.ez.no/eZ-Publish/Upgrading/Direct-upgrading/Direct-upgrading-to-5.1-from-4.7/Direct-upgrading-from-4.7-to-5.1

 

The config file ezpublish.ym has been succesfully updated and has all the informations of the 4.3 installation (database settings, image filters etc )..

But when I run the following command : .php ezpublish/console config:dump-reference ezpublish

It returns a default config with ezdemo etc.

When I try to access the site, I get the wizard page.

I can't figure what went wrong.

Saturday 12 October 2013 2:04:12 pm

Hi Guys,

I was following your comments and trying to update my ezpublish installation from 4.4 to 2011.4 (4.5).

I do everything mentioned and everything looks not bad but I get nothing on the front site of my web site and Strangely I got no error in my log/error.log.

and one more strange point is that admin site, is working perfect and I have everything there!

 

I would appreciate if someone can help me

Tuesday 15 October 2013 9:28:35 am

Hi Amir,

I've had this happen a couple of times but I can't remember the specific reason why - I think there are a few ways it can happen.  You're talking about a completely white page, right?  Is there any source at all?

Is it just the front page or any deeper pages?  can you go to /content/view/full/<x> and is it the same?  Can you see the frontend page preview in the backend?

The first thing to do is clear the cache - when in doubt clear the cache.  I had a site with a weird cache-block problem that would at some point generate a blank page. 

The next thing to do is look in the log files and debug output - chances are the answer is there.  With debug enabled can you see debug output?

Tuesday 17 December 2013 12:01:54 am

Hi Steven, 

 

A bit late but I said it is better to leave a comment for future use.

 

The whole problem was an extension called "birthday" which is a datatype extension for old ezpublish and that extension make the whole website down!

 

so a buggy extension can destroy everthing happy.gif Emoticon

 

I update the extension from it's github and it works perfect now.

 

P.S: there was no error in error log in my case.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from