This site has been archived. To learn more about our current products Ibexa Content, Ibexa Experience, Ibexa Commerce head over to the Ibexa Developer Portal

eZ Community » Forums » Install & configuration » Upgrade trouble eZ 4.3 -> 4.4
expandshrink

Upgrade trouble eZ 4.3 -> 4.4

Upgrade trouble eZ 4.3 -> 4.4

Friday 22 October 2010 11:05:04 am - 11 replies

hi,

recently I tried upgrading from eZ 4.3 to 4.4. Templates and extensions are all loaded, but I cannot log in no matter what siteaccess. I figured it must be a problem with session handling. So I tried a fresh 4.4 install on the same target system which works out of the box and compared the ini settings with the 4.3 install. Afterwards I altered the 4.3 session settings to meet the default 4.4 installation values. the altered installation v4.3 works, but upgrading still does not work = same error. I did ezcache purge and modfix.sh but no luck.

Ini-settings v4.3 in override/site.ini.append.php

[Session]
RememberMeTimeout=
Handler=
SessionTimeout=259200
ActivityTimeout=3600
ForceStart=disabled
SessionNameHandler=custom
SessionNamePrefix=eZSESSID
SessionNamePerSiteAccess=disabled
BasketCleanup=cronjob
BasketCleanupTime=120
BasketCleanupIdleTime=2
BasketCleanupFetchLimit=3000
BasketCleanupAverageFrequency=10

Ini-settings v4.4 in override/site.ini.append.php

[Session]
SessionNameHandler=custom

Has anyboy ran into a similar problem? Any ideas?

Hints are greatly appreciated.

Best wishes

Sebastian

Modified on Friday 22 October 2010 11:06:12 am by Sebastian Schoeller

Friday 22 October 2010 11:54:44 am

have you run the DB sql script?

Friday 22 October 2010 11:55:54 am

(have you made a full backup before upgrade? both DB and Codes, I mean)

Friday 22 October 2010 11:58:41 am

also what was the error message when you tried to login (if any)?

Friday 22 October 2010 12:50:12 pm

Have you tried claring your browser cache? (cookies) if that help change SessionNamePrefix to force new sessions for all users.

Try chaning to db handler (preferably before you upgrade so sessions keeps on working like before upgrade), same as was used in 4.3 by changing setting to Handler=ezpSessionHandlerDB

Try to debug if you have a session cookie at all, and that it changes value when you login.

Try to debug what kind of session data including user id you have by adding this to end of index.php:
var_dump( eZSession::get() );

Modified on Friday 22 October 2010 12:50:41 pm by André R

Friday 22 October 2010 5:06:13 pm

Thanks for the quick hints

@Jacobi

1. I did run the sql upgrade

2. I am running in a different database, so there is backup

3. there is no error message in user view. In admin view I receive error message that I have no right to access

@Andre

1. I cleared browser caches -> nothing

2. I changed handler setting in old installation, purged and upgraded as described in the docs -> nothing

3. cs lite forefox addon tells me that a cookie is set "is_logged_in" after logging in. before logging in I see debug info

array(2) { ["LastAccessedModifyingURI"]=> string(0) "" ["eZUserLoggedInID"]=> string(2) "14" }

and afterwards I get

array(2) { ["LastAccessedModifyingURI"]=> string(0) "" ["eZUserLoggedInID"]=> string(2) "91" }

so the user ID is changed indeed, but I cannot see it in the header links part. btw I could not upgrade the ezwebin packages yet. I hope it has nothing to do with it.

4. I delete the cookies/browser cache, accept globally all cookies in cs lite addon -> nothing

Further ideas would be very much appreciated.

Best wishes

Sebastian

Friday 22 October 2010 5:14:43 pm

@Andre:

I trunkated ezsession table and the user id in the debug output is reset, so I presume the handler setting is set correctly to db usage.

Best wishes

Sebastian

Saturday 23 October 2010 2:14:37 pm

I added

{$current_user|attribute(show)}

to page_header_links.tpl. So after logging in I get contradicting information.

$current_user says:

is_logged_in=false
 
login=anonymous

var_dump says:

array(2) {
  ["LastAccessedModifyingURI"]=>
  string(0) ""
  ["eZUserLoggedInID"]=>
  string(2) "91"
}

Also I reviewed the database upgrade and applied path http://issues.ez.no/IssueView.php?Id=17453, which lead to successful execution of updatesectionidentifier.php, but still in vain after cache purging.

Hints are very much appreciated.

Best wishes

Sebastian

Modified on Saturday 23 October 2010 2:36:42 pm by Sebastian Schoeller

Saturday 23 October 2010 3:04:31 pm

Ok, I found the problem. Changing DebugByUser to disabled let's me log in and log out as usual. Changing it back to DebugByUser=enabled leaves me with the described situation.

Best wishes

Sebastian

Sunday 24 October 2010 11:43:48 am

Strange, could you create an issue for this? (since your the one with most knowledge of it right now)

Tuesday 26 October 2010 4:28:06 pm

@Andre: done & cheers for your time

http://issues.ez.no/IssueView.php?Id=17550&activeItem=1

Thursday 10 March 2011 11:19:06 pm

Thanks thanks thanks thanks thanks thanks thanks thanks thanks !

I've had the same problem for many times, that's why I didn't upgraded to 4.4. I just made it again with little to no trouble happy.gif Emoticon

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from