This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Install & configuration » Upgradescripts 3.3-5 to 3.4.0 produce...
expandshrink

Upgradescripts 3.3-5 to 3.4.0 produce error

Upgradescripts 3.3-5 to 3.4.0 produce error

Thursday 24 February 2005 10:37:01 am - 12 replies

I placed this as an article comment as well, sorry (don't know how to remove it).

I'm following the complete upgrade-path from 3.3-4 to 3.5.0 (via 3.3-5, 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4). Installation of 3.3-5 went well, but when I tried to run the update-scripts from 3.3-5 to 3.4.0 I get the following message:

PHP Fatal error: [] operator not supported for strings in EZP/lib/ezutils/classes/ezini.php on line 632

Anyone know how to solve this?

Thursday 24 February 2005 10:42:57 pm

I've had similar trouble with the update-scripts using phpMyAdmin. Manually removing the comments starting with -- do the trick for me.

roy

Friday 25 February 2005 8:26:33 am

Thanks for the reply, but I don't have a problem with the MySQL update scripts. It's the PHP scripts (in /update/common/scripts) that produce the error. Sorry, should have said. Has anyone else come across this problem?

Monday 28 February 2005 9:23:00 am

Can anyone help? I'd really like to upgrade to the latest release, but it just won't work. If you need more information, please ask.
TIA,

Vivienne

Thursday 03 March 2005 10:11:11 am

Maybe someone from the EZ team? I can't imagine that I'm the first one to experience this problem.

Thursday 03 March 2005 12:54:49 pm

Which PHP version are you using? Please check the PHP version of the CLI (command line) version of PHP as well.

--bård

Thursday 03 March 2005 3:31:13 pm

PHP as shown in EZP admin-interface: 4.3.3
PHP as shown on CLI: 4.3.3

Friday 04 March 2005 12:54:20 am

Given the error message and the file it occured in I suspect that ez is reading an ini file value, expecting an array and getting a string.

You may have to add some debugging to lib/ezutils/classes/ezini.php to file which var in which file is causing the issue.

Which update script are you running when this error occurs?

Cheers
Bruce

Tuesday 08 March 2005 8:54:05 am

Hi Bruce,

I tried all the scripts that are mentioned in the upgrade-documentation for 3.4:
- updateremoteid.php
- updatesession.php
- updatetoplevel.php
- addorderemail.php

They all produce the same errormessage.

Vivienne

Friday 11 March 2005 8:31:50 am

Hi Vivienne

> They all produce the same error message.
It seems there is a string in an ini file where ez is expecting an array. Given that it is happening for all update scripts I'd start checking the siteaccess and override site.ini files against the distribution ones in the settings directory.

Cheers
Bruce

Monday 14 March 2005 10:56:52 am

Hi Bruce,

I moved all my *.ini.append.php files to a different folder, after which the updatescript runs. This would indicate that there is indeed something wrong with my *.ini.append.php scripts. I then minimalised the site.ini.append.php file to:

[DatabaseSettings]
Database=ezpublish_tmp

And placed this file in /settings/siteaccess/mysite/
This is now the only file in this directory. I ran the updatescript again and the same errormessage appeared. To minimalise even further, I even took out the text above, and still the updatescript gives the error. It seems that the only way that I can avoid the errormessage is to remove all *.ini.append.php scripts. I'm guessing that's not the way to go about it, though.

I'm stumped, please help sad.gif Emoticon.

Vivienne

Wednesday 23 March 2005 9:30:16 am

OK, I don't like adding another entry just to get this post back in the picture, but I'm still not able to run the upgradescripts, even with minimalised *.ini.append.php scripts.
Does anyone have an idea what the cause of this strange (and apparently unique) behaviour is?
TIA,

Vivienne

Wednesday 13 April 2005 10:54:01 am

OK, again kicking this post back to the top. I REALLY want to upgrade, but apparently am not able to when I have override scripts in the settings/siteaccess/design directory. As mentioned before, I tried with a completely stripped down version of site.ini.append.php and that didn't work either. Is it possible to upgrade without the scripts in the directory and after the upgrade place them back? Bit of a hack, but I'm at my wits end. Once again: please help sad.gif Emoticon.

Vivienne

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from