eZ Community » Forums » Install & configuration » V2.2.7 Desktop Edition Problem - "No...
expandshrink

V2.2.7 Desktop Edition Problem - "No XML data in HTTP response"

V2.2.7 Desktop Edition Problem - "No XML data in HTTP response"

Tuesday 08 April 2003 12:10:24 pm - 2 replies

Hi all,

I could need your help.

The following is a bit lengthy but I thought you might need all that info in order to help me.

This morning I had downloaded the Desktop Edition for eZ publish 2.2.7. After installation I tried it with the 'publishdemo.ez.no' test site and it worked, so I assume my DE installation is okay.

So I bought a license. The license installation was easy and fine.

I do not intend to use my DE for our intranetnet site, whose home page is located at 'http://naut.dewe.astrazeneca.net:81/op' (don't try to access it, you cannot reach it through our firewall).

But horribly, every time I try to access our site through DE, I receive the error message, >>failed to access host "naut.dewe.astrazeneca.net:81". There was no XML data in the HTTP response.<<

Needless to say that that the site is available and runs like a charm. This ist also not a DNS problem since I can ping our site, and a test with the IP address (instead of the name) yielded the same strange result.

What I find interesting is the "Path" configuration variable in DE. It is nowhere documented, though I guess it is the key to solve my problem. For the publishdemo site, it contains the value "/xmlrpc", again, something that's not documented. Unfortunately this path does not work for my site (a pretty much default installation!) because there is no such directory!?!?!? I do have a ezxmlrpc directory, but this does not work.

Sigh.

Can someone help me, please. I am totally stuck, 50 dollars poorer than before, and don't know how to go on. Thank you very much indeed.

--Michael

Modified on Tuesday 08 April 2003 12:11:05 pm by Michael Meron

Tuesday 08 April 2003 12:45:12 pm

In short:
If you use a virtual host apache config, enter "/xmlrpc" in the "Path" entry. The directory does not have to exist.

If you don't use virtual host, enter "/index_xmlrpc.php". That file should exist in the eZ publish root directory.

Note that your apache config must contain a rewrite rule for xmlrpc. I think this is mentioned in the docs.

DE should connect through the same port as you use in your browser, you can set the port in the login dialog.

DE works out-of-the-box on a standard eZ publish 2.2.7 installation, if you run an older version that may cause problems.

regards

Thursday 10 April 2003 8:14:26 am

Gunnstein,

>>If you don't use virtual host, enter "/index_xmlrpc.php". That file should exist in the eZ publish root directory.<<

BINGO !!! happy.gif Emoticon

Thank you SO very much indeed !!

Two comments on this, however, if I may.

(1) You may be interested to know that this does not (!) work in conjunction with a proxy server. I had to remove (!) the proxy server configuration in order to make DE work. Since our inTRAnet server is on "our" side of the firewall, this did not hurt. However, it is a very strange thing and you should definitely fix that. When hunting the bug, concentrate on proxy configuration when port# is not 80.

(2) You may eventually want to include a documentation of the PATH variable with the DE download. To better understand the situation as it is right now, imagine you have bought a new car, but you cannot find the key. When you ask the vendor, he says, "Oh didn't I tell you, you must dance around the chimney of your house, four times at moonlight, and then a ghost will appear and give you the key."
It should be easier than that. happy.gif Emoticon

Thanks again for your help, and have a nice day,
--Michael

Modified on Thursday 10 April 2003 8:14:50 am by Michael Meron

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from