eZ Community » Forums » Install & configuration » WebDAV configuration; webdav.php is...
expandshrink

WebDAV configuration; webdav.php is not running. (Win XP SP3, xampp1.7.3)

WebDAV configuration; webdav.php is not running. (Win XP SP3, xampp1.7.3)

Monday 21 February 2011 10:31:27 pm - 7 replies

I have probably read all the information and lost a lot of time.
My configuration with "Server Name" instead of "Server Alias". <does not work>. Two of the many rules for webdav.php are in the configuration. I am newbie and have no idea of PHP and Apache. OK, eZ also not. I need some general help and needs to know where the fault lies with webdav. Windows, my understanding or my configuration. It is a test project to learn. I can play also. But now my questions.

  1. Includes 4.4 ez really an own WebDAV server?
  2. If so, can Apache WebDAV and WebDAV eZ run atthe same time?
  3. I set up WebDAV drives. These work. Sorry, no php files are executed. Is my configuration correct?

KONFIGURATIONSDATEIEN:
---------------------------
httpd-dav.conf
---------------------------
<IfModule dav_module>
<IfModule dav_fs_module>
<IfModule setenvif_module>
<IfModule alias_module>
<IfModule auth_digest_module>
<IfModule authn_file_module>
DavLockDB "C:/Testserver/xampp/apache/logs/Dav.Lock"
# ------------------https://webdav.ez.loc------------------------
Alias / "E:/proj/www/ez/htdocs/"
<Directory "E:/proj/www/ez/htdocs">
SSLRequireSSL
Dav On
Order allow,deny
Allow from all
AuthType Basic
AuthName "WebDAV eZ"
AuthUserFile "E:/proj/www/ez/security/.htpasswd"
<LimitExcept GET OPTIONS>
Require valid-user
</LimitExcept>
</Directory>
# ----------------------------------------------------------------
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "MS FrontPage" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[0123]" redirect-carefully
BrowserMatch "^gnome-vfs/1.0" redirect-carefully
BrowserMatch "^XML Spy" redirect-carefully
BrowserMatch "^Dreamweaver-WebDAV-SCM1" redirect-carefully
BrowserMatch "MSIE" AuthDigestEnableQueryStringHack=On
</IfModule>
</IfModule>
</IfModule>
</IfModule>
</IfModule>
</IfModule>

----------------------------
http-vhost.conf
----------------------------
NameVirtualHost 127.0.0.7:80
<VirtualHost 127.0.0.7:80>
<Directory "E:/proj/www/ez/htdocs">
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>
<IfModule mod_php5.c>
php_admin_flag safe_mode Off
php_admin_value register_globals 0
php_value magic_quotes_gpc 0
php_value magic_quotes_runtime 0
php_value allow_call_time_pass_reference 0
</IfModule>
DirectoryIndex index.php
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^/([^/]+/)?content/treemenu.* /index_treemenu\.php [L]
RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]
RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* - [L]
RewriteRule ^/design/[^/]+/(stylesheets|images|javascript)/.* - [L]
RewriteRule ^/share/icons/.* - [L]
RewriteRule ^/extension/[^/]+/design/[^/]+/(stylesheets|flash|images|lib|javascripts?)/.* - [L]
RewriteRule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
RewriteRule ^/var/storage/packages/.* - [L]
RewriteRule ^/favicon\.ico - [L]
RewriteRule ^/design/standard/images/favicon\.ico - [L]
RewriteRule .* /index\.php
</IfModule>
DocumentRoot "E:/proj/www/ez/htdocs/"
php_admin_value upload_tmp_dir "E:/proj/www/ez/htdocs/tmp/"
php_admin_value session.save_path "E:/proj/www/ez/htdocs/tmp/"
ErrorLog "E:/proj/www/ez/logs/ez-error.log"
CustomLog "E:/proj/www/ez/logs/ez-access.log" combined
ServerAdmin postmaster@ez.loc
ServerName ez.loc
ServerAlias www.ez.loc
</VirtualHost>
#-------------https://webdav.ez.loc------------------------------
<VirtualHost 127.0.0.7:80>
<Directory "E:/proj/www/ez/htdocs">
Options FollowSymLinks
AllowOverride None
</Directory>
DocumentRoot "E:/proj/www/ez/htdocs/"
RewriteEngine On
RewriteCond %{HTTP_HOST} ^webdav\..*
RewriteRule ^(.*) /webdav.php [L]
# Rewriterule .* /webdav.php
RewriteLog "C:\Testserver\xampp\apache\logs\rewrite.log"
RewriteLogLevel 9
ErrorLog "E:/proj/www/ez/logs/dav_ez_error.log"
CustomLog "E:/proj/www/ez/logs/dav_ez_access.log" combined
ServerName webdav.ez.loc
</VirtualHost>
----------------------------
hosts
----------------------------

127.0.0.1 localhost
127.0.0.7 www.ez.loc # Testprojekt local 25.01.2011 Apache on Xampp
127.0.0.7 ez.loc # Testprojekt local 25.01.2011 Apache on Xampp
127.0.0.7 ez # Testprojekt local 25.01.2011 Apache on Xampp
127.0.0.7 webdav.ez.loc # Testprojekt local 15.02.2011 Apache on Xampp
127.0.0.7 admin.ez.loc # Testprojekt local 17.02.2011 Apache on Xampp
----------------------------

webdav.ini
----------------------------
[GeneralSettings]
EnableWebDAV[] override true
Logging[] override enabled
StartNode[] siteaccess 2
----------------------------
site.ini
----------------------------
[SiteSettings]
SiteList[] default [0]
SiteList[] override [1] ezflow_user
SiteList[] override [2] ger
SiteList[] override [3] eng
SiteList[] override [4] ezflow_admin
SiteList[] override [5] iphone
------------------------------------------------------
------------------------------------------------------

LOGDATEN:
Mainserver "localhost 127.0.0.1" [ERROR-Log]
[Tue Feb 22 02:23:53 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 22 02:23:53 2011] [notice] Digest: done
[Tue Feb 22 02:23:54 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l
mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured --
resuming normal operations
[Tue Feb 22 02:23:54 2011] [notice] Server built: Nov 11 2009 14:29:03
[Tue Feb 22 02:23:54 2011] [notice] Parent: Created child process 948
[Tue Feb 22 02:24:00 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 22 02:24:00 2011] [notice] Digest: done
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Child process is running
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Acquired the start mutex.
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Starting 150 worker threads.
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Starting thread to listen on port 443.
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Starting thread to listen on port 443.
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Starting thread to listen on port 80.
[Tue Feb 22 02:24:01 2011] [notice] Child 948: Starting thread to listen on port 80.

Mainserver "localhost 127.0.0.1" [ERROR-Log]
<Windows Webclient>
[Tue Feb 22 02:26:10 2011] [error] [client 127.0.0.7] client denied by server configuration:
E:/proj/www/ez/htdocs/.htaccess
<BitKinex>
[Tue Feb 22 02:39:44 2011] [error] [client 127.0.0.7] client denied by server configuration:
E:/proj/www/ez/htdocs/.htaccess
Mainserver "localhost 127.0.0.1" [ACCESS-Log]
127.0.0.7 - - [22/Feb/2011:02:25:51 +0700] "PROPFIND / HTTP/1.1" 401 1580 "-" "Microsoft Data Access
Internet Publishing Provider DAV"
<Dateizugriff (*.txt)>
127.0.0.7 - User [22/Feb/2011:02:26:10 +0700] "PROPFIND / HTTP/1.1" 207 30087 "-" "Microsoft Data
Access Internet Publishing Provider DAV"
127.0.0.7 - - [22/Feb/2011:02:37:34 +0700] "PROPFIND / HTTP/1.1" 401 1418 "-" "BitKinex/3.2.3"
127.0.0.7 - User [22/Feb/2011:02:37:45 +0700] "PROPFIND / HTTP/1.1" 207 20306 "-" "BitKinex/3.2.3"
127.0.0.7 - - [22/Feb/2011:02:39:44 +0700] "PROPFIND / HTTP/1.1" 401 1418 "-" "BitKinex/3.2.3"
127.0.0.7 - User [22/Feb/2011:02:39:44 +0700] "PROPFIND / HTTP/1.1" 207 20306 "-" "BitKinex/3.2.3"
<Dateizugriff (*.txt)>
127.0.0.7 - - [22/Feb/2011:02:39:47 +0700] "GET /README.txt HTTP/1.1" 200 2558 "-" "BitKinex/3.2.3"
<Dateizugriff (webdav.php)>
127.0.0.7 - User [22/Feb/2011:02:57:19 +0700] "PROPFIND / HTTP/1.1" 207 20306 "-" "BitKinex/3.2.3"
127.0.0.7 - User [22/Feb/2011:02:57:22 +0700] "GET /webdav.php HTTP/1.1" 404 - "-" "BitKinex/3.2.3"

Tuesday 22 February 2011 10:03:03 am

Hi,

I had work with webdav with eZ some time ago it worked fine. Can you turn off Apache webdav module and try again ?

Tuesday 22 February 2011 6:09:14 pm

Thanks Yannick, for the reply. There is not the right way. DAV_Module off and exclude the hhtp-dav.conf does not help. The way from the manual does not work.

http://doc.ez.no/eZ-Publish/Techn.../4.x/Installation/Virtual-host-setup

The normal configuration for DAV in the http-dav.conf results for all other domains "403". Do not worry, eZ continues. Someone had an idea. How is working the WebDAV from eZ? Where is my wrong? I show you something nice too. The following example matches all domains of the server.

http-dav.conf

DavLockDB "C:/Testserver/xampp/apache/logs/Dav.Lock"
...
Alias / "E:/proj/www/ez/htdocs/"
<Directory "E:/proj/www/ez/htdocs">
Dav On
Options FollowSymLinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>

http-vhost.conf

http-vhost.conf
...
RewriteRule .* index\.php
#RewriteRule .* /index\.php
...

Result for 10.0.0.2 (www/contao.loc)

Warning: require() [function.require]: open_basedir restriction in effect. File(E:\proj\www\ez\htdocs\autoload.php) is not within the allowed path(s): (E:/proj/www/contao/htdocs/) in E:\proj\www\ez\htdocs\index.php on line 45
Warning: require(E:\proj\www\ez\htdocs\autoload.php) [function.require]: failed to open stream: Operation not permitted in E:\proj\www\ez\htdocs\index.php on line 45
Fatal error: require() [function.require]: Failed opening required 'autoload.php' (include_path='.;C:\Testserver\xampp\php\PEAR') in E:\proj\www\ez\htdocs\index.php on line 45

Today, I have switched all Hosts on IP-based and use for this a virtual interface (Microsoft Loopack adapter). Tomorrow I test everything in name-based hosts, and then I'm going to throw stones into the Pacific.Below my configuration of today. "Order allow, deny" and "Allow from all" do not come from the manual. Without these rules, I could not install.
I hope I have not buried eZ and wish a good night.
Falkmar

<VirtualHost 10.0.0.7:80>
<Directory "E:/proj/www/ez/htdocs">
Options FollowSymLinks Indexes ExecCGI
AllowOverride None
Order allow,deny
Allow from all
</Directory>
<IfModule mod_php5.c>
php_admin_flag safe_mode Off
php_admin_value register_globals 0
php_value magic_quotes_gpc 0
php_value magic_quotes_runtime 0
php_value allow_call_time_pass_reference 0
</IfModule>
DirectoryIndex index.php
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} ^webdav\..*
RewriteRule ^(.*) /webdav.php [L]
RewriteRule ^/([^/]+/)?content/treemenu.* /index_treemenu\.php [L]
RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]
RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* - [L]
RewriteRule ^/design/[^/]+/(stylesheets|images|javascript)/.* - [L]
RewriteRule ^/share/icons/.* - [L]
RewriteRule ^/extension/[^/]+/design/[^/]+/(stylesheets|flash|images|lib|javascripts?)/.* - [L]
RewriteRule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
RewriteRule ^/var/storage/packages/.* - [L]
RewriteRule ^/favicon\.ico - [L]
RewriteRule ^/design/standard/images/favicon\.ico - [L]
RewriteRule .* /index\.php
</IfModule>
RewriteLog "C:\Testserver\xampp\apache\logs\rewrite.log"
RewriteLogLevel 9
ErrorLog "E:/proj/www/ez/logs/ez-error.log"
CustomLog "E:/proj/www/ez/logs/ez-access.log" combined
DocumentRoot "E:/proj/www/ez/htdocs/"
php_admin_value upload_tmp_dir "E:/proj/www/ez/htdocs/tmp/"
php_admin_value session.save_path "E:/proj/www/ez/htdocs/tmp/"
ServerAdmin postmaster@ez.loc
ServerName ez.loc
ServerAlias webdav.ez.loc
ServerAlias www.ez.loc
</VirtualHost>

Wednesday 23 February 2011 9:54:08 am

Hi,

For resuming, WebDAV work like follow : the eZ Webdav suppose that not mod_dav is not installed, the class create appropriate webdav header to send in client according request.

Wednesday 23 February 2011 11:09:22 pm

First, I'd like to answer your questions:

1. Includes 4.4 ez really an own WebDAV server?.
Yes, eZ currently comes with a WebDav php handler that behaves like a WebDav Server.

2. If so, can Apache WebDAV and WebDAV eZ run atthe same time?
Yes, but you shouldn't do it over the same directory or domain, so turn off the Apache Dav Module and try again.

3. I set up WebDAV drives. These work. Sorry, no php files are executed. Is my configuration correct?
I guess that you've configured those drivers under an IP based schema and not using a domain, so in this way only the Dav Module is invoked. I suggest that you use only the eZ Publish Web Dav implementation.

Your last vhost configuration seems well. eZ Publish comes with its own WebDav Server, so turn off all the WebDav server configurations that applies to the eZ Publish installation directory and then test it using webdav.ez.loc as URL.

Thursday 24 February 2011 9:07:39 am

Thanks Bayron. These are good descriptions. I had to figure it out experimentally. I just wanted to learn eZ and now I dream of Indians.
1. I switched off the Apache DAV complete. eZ continues to work with DAV clients.
2. Joo, Byron. I have tried this route and lost the complete server. There are many problems with user rights and override if the server is not configured correctly. Here I miss a sentence in the manual. "Never use the DAV modules of the Apache for WebDAV server from eZ in a vhost basing IP." (ok, with better english)
3. Thank you for the very important point. Yes, I only use IP-based hosts on the basis of a virtual interface.

Everything works. I just had a global rule in the "httpd.conf" set for my project paths.

<Directory "E:/proj/www/*/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Now everything is running fine in the standard. The configuration can be copied directly from the manual. Only the temporary storage needs to be adjusted if necessary. This advice comes in the setup wizard if you do not have write permission on the root master server.
eZ is probably a really well-designed system, if one knows how it works happy.gif Emoticon

Now I have time for the next problem. WebClient. The choice was not difficult. Nothing works in Windows. Only the WebClient Windows and BitKinex.
The WebClient in XP is super comfortable, but just MSIE + service "WebClient"+ problems.
"BitKinex" needs "Webclient" service not, is super easy to install and run without problems (so far)

Thanks Bayron and Yannick my Problem is fixed

Thursday 24 February 2011 10:17:20 am

Now I have time for the next problem. WebClient. The choice was not difficult. Nothing works in Windows. Only the WebClient Windows and BitKinex.

Do you try with Dav Explorer ? http://www.davexplorer.org/ i usually use it.

Thursday 24 February 2011 12:06:39 pm

Wow, that's something really challenging. Link from the desktop to the "DAVExplorer.bat" and ready. My Dos was a little shaken. Probably too much Dust (2005) happy.gif Emoticon. works great, thanks

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from