This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » [3.3.0-2] Virtual url doesn't work
expandshrink

[3.3.0-2] Virtual url doesn't work

[3.3.0-2] Virtual url doesn't work

Wednesday 24 December 2003 12:50:24 pm - 4 replies

Hi,

I was just playing around with ezPublish 3.3.0-2. I installed the corporate 'site' in the install.
Now, I saw the URL Translator. The way I see it, you just have to enter a 'System URL' (in my case: corporate/content/view/full/124) and a 'Virtual URL' (in my case: bottom).
I stored it, but there's no way I can access it. I tried:
- http://www.mydomain.com/index.php/bottom
- http://www.mydomain.com/index.php/corporate/bottom
- http://www.mydomain.com/bottom (which of course didn't work)

What do I do wrong here? (or is it a know bug or something?)

-- Mark

Wednesday 24 December 2003 1:30:56 pm

Hmm, strange..

Take a look at the ezurlalias table in the database, does it actually contain the values that you entered? You could do something like this:

SELECT source_url, destination_url from ezurlalias;
(don't remember the exact names.. the example above might be incorrect)

Balazs

Modified on Wednesday 24 December 2003 1:31:50 pm by Balazs Halasy

Wednesday 24 December 2003 1:32:19 pm

Maybe you have to clear the cache first? Haven't tried it, but maybe...

Wednesday 24 December 2003 2:21:06 pm

Removed the cache. Didn't work. Here's what did:

I searched the database (select * from ezurlalias) and saw that 'content/view/full/xx/' is normally used, instead of 'corporate/content/view/full/xx/'.
If I remove 'corporate', it works fine. But that's weird. When I go to 'www.mydomain.com/index.php/corporate/content/view/full/xx/' it works great, but it doesn't work at all if I try to use it with a virtual URL...

I know how to use it now, but I would like to know why it doesn't work the way I thought it would work. Will this be changed in the future? Not that it is necessary, but I just think it should work.

-- Mark

Wednesday 24 December 2003 4:34:37 pm

So, you got it working, eh? Great! happy.gif Emoticon

You don't have to include the name of the siteaccess ( in this case "corporate" ) when setting up the virtual URL. Actually, I don't think that you can (because of how the system is designed and how it actually works). Sorry, I didn't see the "corporate" part when I was reading your first post. The "index.php" and the "corporate" part of the URL is usually not shown (take a look at the URLs of a pro eZ publish site). However, they are shown in your installation because you probably chose the default access mode when you set up eZ publish. There are other ways to set it up. I suggest that you check out the following links:

http://ez.no/developer/ez_publish...on/ez_publish_basics/ez_publish_urls

and

http://ez.no/developer/ez_publish...figuration/configuration/site_access

The bottom line is that you can't include the name of the siteaccess when using the URL translator.

Balazs

Modified on Wednesday 24 December 2003 5:16:29 pm by Balazs Halasy

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from