This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Brooken template or broken class? How...
expandshrink

Brooken template or broken class? How to Fix.

Brooken template or broken class? How to Fix.

Tuesday 21 August 2012 7:10:54 am - 4 replies

I think I have broken the main article class... I almost sure. I removed the ezstarrating extension and it broke.

Is there a way to revert or fix this? in the DB? I really need help here today... I have a 1 day old database so I may compare it or take inf from it but I cant lose information.

Hope to find some help. Thanks in advance.

Tuesday 21 August 2012 8:01:31 am

Hi Luis, it's hard to tell what exactly went wrong since you aren't saying how it is broken.... but I'm going to guess that you removed the ezstarrating extension - that has the ezstarrating datatype - while still having the datatype as a class attribute of your main article class.

If you try and edit an object of a class with a datatype that isn't defined you will get a fatal error.  Depending on your error display settings that could just be a blank page.

What you want to do is make sure the datatype has been removed from all your classes - I don't remember for sure, but you will might have to re-enable the extension to edit the classes.

Tuesday 21 August 2012 8:16:12 am

Steven,Thanks for your advice. I removed the starrating and then I think that while trying to remove translations from the object, I saved it and broke the class with no starrating... Even reloading the extension and adding the atreibute wont work. I finally went for the last backup from yesterday and lost all the content from yestarday... I have learned the hard way to FIRST remove the attribute and THEN the extension.

Tuesday 21 August 2012 12:33:45 pm

Glad you sorted it out Luis - please mark this issue as resolved, by clicking the speech bubble icon next to the issue title.

Cheers,
Geoff 

Thursday 23 August 2012 7:38:20 pm

I will mark this solved but in fact it was unfortunatley never solved...a broken content attribute brokes the content.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from