eZ Community » Forums » Setup & design » Browsing the media section
expandshrink

Browsing the media section

Browsing the media section

Thursday 05 January 2006 7:21:35 pm - 1 reply

Hi there,

I want to display images thumbnail when browsing the media section instead of the "image class" icon.

I assume I should modify the following template:
/design/admin/templates/node/view/browse_thumbnail.tpl and do a {if} on the class identifier. If the class identifier is an image then I should display a specific view of the node, as for instance, the embed view ... The problem is that I got nothing displayed when trying to do it with the following line of code:

{if eq($node.class_identifier,'image')}
 {node_view_gui content_node=$node view=embed}
{else}
 {$node.class_identifier|class_icon( normal, $node.object.class_name ) } {* the normal way *}
{/if}

Any idea of what the problem could be. Or how would you do it yourself ?

Thanks,
C.

Friday 06 January 2006 9:04:18 am

When viewing the media section I simply click the viewmode buttons below the objects header. You can choose between List, Thumbnail and Details. Thumbnails are then displayed!

However, when inserting an image through OE this doesnt work: If you click the thumbnail-view-link when choosing an image, the thumbnails are simply displayed as document-icons. How can I make ez publish show me real thumbnails instead?

This should really be the default functionality when installing ez!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from