This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Can't send Email SMTP in ez publish 5.4
expandshrink

Can't send Email SMTP in ez publish 5.4

Can't send Email SMTP in ez publish 5.4

Monday 16 March 2015 12:38:00 pm - 9 replies

Hi to all,

I need your help, Please, I hope someone can help,
My problem is that i can't send or receive email, i added the following settings  to the site.ini located in D:\EasyPHP-5.3.3\www\ezpublish5.4\ezpublish_legacy\settings :

Transport=sendmail
# A list of possible handlers for sending mails, use the setting Transport to specify which one to use
TransportAlias[]
TransportAlias[file]=eZFileTransport
TransportAlias[sendmail]=eZSendmailTransport
TransportAlias[smtp]=eZSMTPTransport
# Configuration for SMTP
TransportServer=smtp.gmail.com
# Connection type in SMTP: <empty>(no encryption)|ssl|sslv2|sslv3|tls
TransportConnectionType=ssl
# Default SMTP port is 25, default Secure SMTP port(SSL,TLS) is 465
TransportPort=465
TransportUser=bakrim.issam@gmail.com
TransportPassword=mypassword
SenderHost=localhost
AdminEmail=bakrim.issam@gmail.com
# The address which will be set as the From header of the e-mail, unless
# overridden by the template variable email_sender.
EmailSender=bakrim.issam@gmail.com
DebugReceiverEmail=bakrim.issam@gmail.com

 

And the configuration of Proxy :

ProxyServer=**********:9090
User=issam.bakrim
Password=************

Has somebody done something similar or perhaps I have misspelled the topic search within the forum posts. Anyhow I would be very glad if someone could point me in the right direction.

Best wishes

Issam.

Modified on Monday 16 March 2015 2:21:48 pm by bakrim issam

Monday 16 March 2015 3:59:52 pm

Hello Issam,

I've never configure a google account to send mail directely from EZ, but did you tried :

TransportServer=smtp.googlemail.com

 

Regards Alex.

Monday 16 March 2015 4:31:06 pm

I've tried it but it doesn't work :

I have this error :
[ Mar 16 2015 16:26:26 ] [127.0.0.1] eZSMTPTransport::sendMail:
An error occured while sending or receiving mail. Failed to connect to the smtp server: :465.
[ Mar 16 2015 16:26:26 ] [127.0.0.1] Timing Point: Module end 'content'

what did you use as TransportServer ? My objective is to send/to receive email no matter what the TransportServer is.

Modified on Monday 16 March 2015 4:32:56 pm by bakrim issam

Monday 16 March 2015 4:58:05 pm

As I said, I did'nt use EZP with gmail SMTP.

I use EZP ( default settings ) wich use sendmail and I configure sendmail to use a gmail account. Sendmail is a linux ( unix ) process, nothing to do with EZ. You can configure it from this tuto : http://linuxconfig.org/configuring-gmail-as-sendmail-email-relay

There might be an other solution, ( as you want to do ) but I don't know how to, maybe can someone else give some help ?

Alex.

Monday 16 March 2015 6:24:23 pm

Okey Thanks Alex,

I've configured also Sendmail, but unfortunately it doesn't work,

I've spent 4 days to solve this problem but no way, I still can't send mail.

Please, Has somebody done something similar or have the answer, Anyhow I would be very glad if someone could give me a hand.

Best regards

Issam,

Modified on Monday 16 March 2015 6:29:36 pm by bakrim issam

Monday 16 March 2015 6:32:45 pm

It sound like the problem cames from a misconfiguration from your system...

In the link I gave you, there is a test that you can run from your shell. If this test is unsuccessfull, the problem come from your system, so you can dig that way.

Alex.

Monday 16 March 2015 7:24:17 pm

I'm working on Windows 7, so i can't use this tutoriel.

My configuration is as follow :

EasyPHP-5.3.3, and  eZ Publish Community Project 2014.07

Monday 16 March 2015 7:47:34 pm

Hello Bakrim,

Your mail is prolly being refused by gmail/google by default due to security / anti-spam concerns.

Off the top of my head you prolly do not have proper reverse dns, spf, etc just off the top of my head. These days you just can't send mail without taking proper steps beforehand as big servers refuse to support the old ways because of spam.

I've used the same setup your trying to use in the past and encountered this problem myself.

In my situation my mail delivery was delayed and ended up in the gmail spam folder (I was emailing via eZ Publish to a gmail account).

Let me assure you this is not an eZ Publish problem as eZ Mail is stable (rock solid).

You would be better served by reviewing your mail attempts for errors and checking your gmail spam folder for recommendations from google on why your mail is being either refused, delayed or filtered to the spam folder.

You may find debugging using the class helps, I'm not certain: https://github.com/ezsystems/ezpu.../ezutils/classes/ezsmtptransport.php

http://serverfault.com/questions/...orrectly-configure-for-smtp-delivery

Also, Please stop cross posting in the forums trying to get others to post to your thread.

I hope this helps!

Cheers,
Heath

Thursday 26 March 2015 4:11:52 pm

Hi Heath,

My problem was that i have a proxy settings that block the mail to be send, i tried to test sending mail in a place without a proxy settings and it works fine.
by the way i've tried to cross posting in the forums because i was stuck at this problem and i've spent 5 days or more, and i'm a new member here. 

thanks to everybody here, you're the best big-smile.gif Emoticon

Regards, issam

Friday 27 March 2015 9:27:35 am

Hello bakrim,

I'm pleased you were able to find the solution to your problem and that we were able to help!

Thank you for explaining your intentions regarding cross posting.

I understand your frustration but please try to understand that the day that you posted I was unbelievably busy and away from my regular forum duties (sorry for this) and I was delayed in being able to reply to your question.

That said I did reply the same day just as soon as I possibly could and in fact others stepped up to help with replies as well while I was away. 

We try to do the best we can to give expert forum discussions and solutions as quickly as we possibly can, please remember to have patience with us and continue to suppress the urges to cross post as this truly causes more problems than it is worth.

To be honest, almost no one even notices or even can see cross posting, except the forum administrators due to the current design of the forums and it's related views, so in short it's just not going to help anyone to cross post.

Best wishes. Take it eZ!

Cheers,
Heath

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from