eZ Community » Forums » Setup & design » Cannot upload related object
expandshrink

Cannot upload related object

Cannot upload related object

Monday 23 November 2009 4:17:12 pm - 8 replies

Hi all !

i'm trying to upload an attachment in a article. When i'm trying to add a new related object to this article, i'm browsing my file, then i submit the uploading form, and i get an error "The file cannot be uploaded".

I'm using eZ Publish 4.0.0. Can you help me ?

Thanks for your answers. Laurent

Monday 23 November 2009 7:39:11 pm

Might be you do not have rights to create objects in the "media" section, and that's where eZP is set up to create related objects (such as images) in your case.

Either augment editor user rights or set uploaded images to be created as children of edited node.

Tuesday 24 November 2009 11:56:36 am

Hi Gaetano
Thanks for your quick answer.
However, I am the site administrator, so I do not know how I can further increase users' rights (as I have already obtained all rights).
Where can I configure the uploaded items to be a child of the edited node?

Thx

Tuesday 24 November 2009 1:40:09 pm

If your are connected as admin user in eZP, then the problem is different.

Can you check in the eZP error log if there is anything streange?

Wednesday 25 November 2009 10:33:13 am

It says :

[ Nov 25 2009 10:27:01 ] [91.163.198.32] index:Undefined module: design

[ Nov 25 2009 10:27:01 ] [91.163.198.32] error/view.php:Error ocurred using URI: /ezlab/design/standard/images/favicon.ico

I really don't know what to do ? Is this due to OE ?

Wednesday 25 November 2009 3:50:19 pm

The error you are seeing is from a missing line in your apache .htaccess file.

In short: in your pagelayout you have a link to the favicon.ico file in /ezlab/design/standard/images/favicon.ico, but this url is not interoretd by Apache as 'serve from filesystem' and sento to eZP instead. eZP thinks its a bad url and logs the error.

The fix is simple - look up the comments in your .htaccess_root file for examples.

Otoh it is weird that you do not have any message about your error.

You should:

- raise the logging level of eZP to include warning, notice, debug levels (change the Alwayslog setting in site.ini)

- check the php error log, too. Maybe the file you're trying to upload is too big wrt. the max allowed size in php.ini

Thursday 26 November 2009 11:59:26 am

I can't access the php.ini file, because i don't have the whole control of the server. I can't see the php.ini file in my FTP client.

So how do i can raise the logging level of eZP ?

Thx

Thursday 26 November 2009 12:20:40 pm

The contents of php.ini you can see in the admin interface of ezp, in the "setup/system information" page, clicking on the link "details" next to php version. In there you can search for log_errors (it should be on) and error_log. Then you can see if by ftp you have access to the error log; if error_log is empty php will tunnell his errors in the apache error log.

If you cannot read that file, you should imho ask the server admin to be able to access it, read-only. It is often needed for debugging problems.

While looking at the php config, check the values for upload_max_filesize and file_uploads.

To raise the ezp error logging, set in site.ini.append.php:

[DebugSettings]

AlwaysLog[]=warning
AlwaysLog[]=debug
AlwaysLog[]=notice
AlwaysLog[]=strict

Thursday 26 November 2009 2:54:53 pm

I've set the settings, in site.ini.append.php. However, it didn't help.

When i'm trying to access to the "setup/system information" page, there's no link next to php version. The maximum uploaded file size is 8M.

When i'm trying to read the content of .log files, there's no relation between the upload and the .log file's content.

thx

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from