This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Changes in image.ini have no effects
expandshrink

Changes in image.ini have no effects

Changes in image.ini have no effects

Wednesday 17 October 2012 10:58:22 am - 3 replies

Hey.

I have a problem with image types or aliases and filters. I tried to add a new image alias or changing the filter of an exiting alias to make it larger (reference value has been empty). I emptied the cache, uploaded the image again but nether there is an attribute for the new image alias in the image object nor is the image resized to the larger size. Is seams that changing anything in the settings doesn't have any effect. The image that I upload is very large, I also tried to add the changes to /settings/image.ini and I can see the new settings in the ini-editor in the backend. But in the templates nothing changes. Could you please help me to solve that. I am using version 4.0 (yes I should upgrade that but there is only a little bugdet for a little change so I won't).

Wednesday 17 October 2012 12:45:42 pm

First check if you have put an image.ini.append.php in a global settings. Image aliases will be visible to all siteaccesses in that case. Here is an example of how it should look like in the image.ini.append.php:

[MIMETypeSettings]
Quality[]
Quality[]=image/jpeg;75

[AliasSettings] 
AliasList[]=promo

[promo] 
Reference= 
Filters[] 
Filters[]=geometry/scaledownonly=80;80

Output image using code:

 {attribute_view_gui attribute=$node.data_map.image image_class=promo}

You can use an other filters as well, check it in the documentation.

Modified on Wednesday 17 October 2012 12:46:02 pm by Milos Petkovic

Wednesday 17 October 2012 5:35:29 pm

Hello Melos.

Thank you! Your tip solved my problem. Not sure what exactly it was, but now it works! Tahnk you.

Thursday 18 October 2012 8:32:49 am

You're welcome. Please mark it as solved.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from