This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » changing CSS in sitesyle (EZpublish 5.4)
expandshrink

changing CSS in sitesyle (EZpublish 5.4)

changing CSS in sitesyle (EZpublish 5.4)

Thursday 05 March 2015 7:12:40 pm - 4 replies

Hi

I have downoaded EZpublish 5.4 (community edition) and followed the guide to create and install a new sitestyle. https://doc.ez.no/eZ-Publish/User-manual/5.x/The-Website-Interface/Customization-Guide/Creating-a-Site-Style-Package

This has installed successfully, and I went to Design>Look and feel and added my sitestyle there as well.

It created the new css files in the var folder, but I started with some basic changes, just changing colours in the css files but nothing is showing on my site.

Am I changing the correct files? Is there something else I need to do?

 

 

Thanks in advance

 

Barry J

Thursday 05 March 2015 10:22:15 pm

Hello Berry,

Welcome to eZ Community!

When using site style packages to customize css remember to check your siteaccess design.ini.append.php settings to ensure that your site style package css files are being sourced.

Example from file, settings/siteaccess/(your_siteaccess_name)/design.ini.append.php

[StylesheetSettings]
SiteCSS=var/storage/packages/eZ-systems/ezwebin_design_blue/files/default/file/site-colors.css
ClassesCSS=var/storage/packages/eZ-systems/ezwebin_design_blue/files/default/file/classes-colors.css

The above is just an example of the settings, your paths to css files will be different, make sure you can load these file paths from the browser as well.

Also remember that site style packages are quite limited in what can be done to customize the design of eZ Publish Legacy by default. If you really want to customize a design in eZ Publish Legacy we recommend you create a custom design extension with which you can customize -all- css (not just partial) and template markup.

I hope this helps!

Cheers,
Heath

Modified on Thursday 05 March 2015 10:22:47 pm by // Heath

Wednesday 11 March 2015 2:16:09 am

Hi

 

Thanks for getting back to me. As far as I can tell I have follwed what you have said, but I still have nothing changing when I amend the css files.

There is code (which seems automated) in ezpublish_legacy/settings/siteaccess/bandw/design.ini.append.php  which reads:

<span style="color: #000080; background-color: #f7faff; font-weight: bold;">php </span><span style="color: #808080; background-color: #f7faff; font-style: italic;">/* #?ini charset="utf-8"?
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">[StylesheetSettings]
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">SiteCSS=var/storage/packages/local/baan/files/default/file/site-colors.css
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">ClassesCSS=var/storage/packages/local/baan/files/default/file/classes-colors.css
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">CSSFileList[]
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">[JavaScriptSettings]
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">JavaScriptList[]=insertmedia.js
</span><span style="color: #808080; background-color: #f7faff; font-style: italic;">*/ </span><span style="color: #000080; background-color: #f7faff; font-weight: bold;">?></span>

 

 

and my ccs files are:

ezpublish_legacy/var/storage/packages/local/baan/files/default/file/classes-colors.css

and

ezpublish_legacy/var/storage/packages/local/baan/files/default/file/site-colors.css

 

Have I missed anything, or misunderstood something?

 

Thanks again for your help

 

Barry

Wednesday 11 March 2015 2:48:11 am

Hello Barry,

I'm sorry your still having troubles but it seems that more information is required to give you the best answer.

Are you using the new stack (symfony based) at all in any way? This question is important, I'll try to explain quickly ...

If your pointing your apache webserver virtual host DocumentRoot to the ezpublish_legacy directory then your using legacy only and not new stack (symfony based).

If your using legacy only then your settings look correct as-is.

If your using legacy -through- new stack which is often not recommended due to performance issues, I'm not sure the best advice here as the web folder is the doc root for new stack and css is handled much differently by default. Also I've never tried to use site packages using legacy -through- new stack (legacy mode) before. I would think that in general the settings would remain the same (as-is) but I'm honestly not certain due to the difference in web server doc root. 

Have you tried to load the css files in the browser by hand? Do they load? This question is very important!

If your not using new stack but have not pointed your web server virtual host DocumentRoot to the ezpublish_legacy directory you have not setup your web server correctly nor the strongly recommended virtualhost mod_rewrite rules. If your running outside an installation specific virtual host, which should work per-say but in some ways it's harder to support in general depending again on which stack your using.  

I'm afraid I can't answer more specifically without answers to each of my specific questions above and in general more information on how you have setup ezpublish and how you are using ezpublish.

Cheers,
Heath

Friday 17 April 2015 1:00:15 am

Hi

If you are reading this, I am coming back to the thread after some additional research, and Heath is correct the best was to override CSS seems to be to override the whole template.

Since I am wanting to use the Symfony methods rather than legacy, I will connect this thread with another thread dealing with that issue, and hopefully we can all benefit together.

Please go to this link to continue:

 

http://share.ez.no/forums/ez-publish-5-platform/best-way-to-use-override-system-in-ez-publish-5#comment86463

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from