This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » custom design override.ini problems
expandshrink

custom design override.ini problems

custom design override.ini problems

Tuesday 22 July 2003 4:03:14 pm - 2 replies

Having trouble getting my custom design started. I have created my own design called "ca" it is located in /design/ca. I have added the appropriate settings to get it working and changed the pagelayout.tpl to a design I like. I now would like to setup an override to use a different pagelayout for another section. I have added a section called "access" with the Section ID 4. I created a override.ini file in /design/ca/override/ with the following lines:

[access]
Source=node/view/full.tpl
MatchFile=pagelayout_access.tpl
Subdir=templates
Match[section]=4

And I added pagelayout_access.tpl to /design/ca/override/templates with a slightly modified design.

But when I view articles and folders in section 4 they are still rendered the same as the others. All caches have been cleared. Any idea what I missed here?

Tuesday 22 July 2003 4:08:24 pm

Try 'Source=pagelayout.tpl' instead of 'Source=node/view/full.tpl'.

Tuesday 22 July 2003 4:48:40 pm

It appears I put my override file in the wrong place. I added the following lines:

[pagelayout_access]
Source=pagelayout.tpl
MatchFile=pagelayout_access.tpl
Subdir=templates
Match[section]=4

In /settings/siteaccess/ca/override.ini.append

It was not very clear in the documentation that this file goes in the settings folder and not in the design folder. Thanks all.

Modified on Tuesday 22 July 2003 4:49:05 pm by James Ward

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from