eZ Community » Forums » Setup & design » Data Error
expandshrink

Data Error

Data Error

Wednesday 03 June 2015 10:18:54 am - 6 replies

Hello. I've a problem with the version "Community Project 2012.6"
Advance let me say that I am not an experienced Administartor this system.

This system is running about more then one year without the following problem.
Yesterday we published an new article and the the error apears. Now we can´t select one of the existing articles from the submenu ... it appears "Data error"
The article is ok in the frontend.

The backend URL is http://admin.blablabla.de/content/News
What is the problem and how can I solve it?

Thanks in advance for your help

Wednesday 03 June 2015 6:13:31 pm

Hello Massimo,

Welcome to the eZ Community!

What exact version of PHP are you using?

Cheers,
Heath

Monday 08 June 2015 10:16:08 am

Hello  // Health and thank you.
We are using:

PHP Version 5.4.39

Server API CGI/FastCGI
   
   
   
   
   
PHP API 20100412
PHP Extension 20100525

Tuesday 09 June 2015 5:15:36 am

Hello Massimo,

Thank you for answer.

I am sorry your having troubles.

I see now that your currently running a version of PHP which is not supported by your current version of eZ publish.

To solve this problem you will need to upgrade eZ Publish to the 2014.11 Community Build which is the first version which introduced PHP 5.4.x+ compatibility.

What I think has happened is until recently you were running a version of PHP which was compatible with your current version of eZ Publish, then without warning your hosting server was upgraded (possibly by your provider or server administrator) to use the newer version of PHP and thus caused this version compatibility problem.

Upgrading to the 2014.11 Community Build (eZ Publish Platform 5.4+) will solve this problem.

Best wishes! Apologies for my late reply.

Cheers,
Heath

Wednesday 10 June 2015 10:00:07 am

Hello  // Health

thank for the detailed and informative reply!

Just one more question:
Which was the last supported php-version for eZ Publish "Community Project 2012.6"?

Best Regards,

Massimo

Wednesday 10 June 2015 12:40:09 pm

Hello Massimo,

Few weeks ago, I had some troubles like yours. I used the same Community version and I'll quote a part of the answer given to me :

"the community build your using was not designed to run on anything past 5.3"

You can find the complete post here : http://share.ez.no/forums/developer/ez-4.7-problem-with-the-package-import

 

Cheers,

Patrick

Wednesday 10 June 2015 12:50:55 pm

Hello Massimo,

The answer is PHP 5.3 as documented on the download page, http://share.ez.no/downloads/downloads/ez-publish-community-project-2012.6

But -no one- should intentionally avoid an eZ Publish upgrade by reverting an already in place PHP upgrade to a lower version of PHP ... especially since PHP 5.3 has been unsupported for some time now.

Vendors, server hosting providers and GNU/Linux distributions are all moving forward to support the -stable- release of PHP and discontinuing support of PHP 5.3 ... and this should make it clear to you that it would be a mistake to downgrade PHP instead of upgrading eZ Publish.

The right action for you to take is to upgrade, which is not very hard to do at all.

Best wishes

Cheers,
Heath

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from