This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » ez extension migration: missing parts...
expandshrink

ez extension migration: missing parts - ezpagedata issue [SOLVED]

ez extension migration: missing parts - ezpagedata issue [SOLVED]

Monday 25 October 2010 11:29:15 pm - 4 replies

Hi there,

I have to move a project originally based on ezwebin to a new ez installation, both 4.3. The new one is based on a plain_site layout though.

When I installed my new extension package, lots of templates parts where missing starting from the top menu, and instead of the loaded page logo I got a text link.

It seems as if this condition inside pagelayout.tpl is not taken into consideration:

{if $pagedata.top_menu}..

as well as this other one inside page_header_logo.tpl, for instance:

{if $pagedesign.data_map.image.content.is_valid|not()}..

and since $pagedata and $pagedesign come from this code snipped:

{def $pagedata         = ezpagedata()
     ..
     $pagedesign       = $pagedata.template_look
     ..}

I believe it has something to do with ezpagedata().

Any idea? ..Thx!

Modified on Tuesday 26 October 2010 9:21:58 pm by Lo' F.

Tuesday 26 October 2010 10:32:24 am

ezpagedata is an webin operator that does page initialization in php for speed, and instead of being able to change it direclty you can customize it's result with persistent variable and / or parameter hash to operator.

plain site is old, and does not have any of this features that webin has been getting over the years, so hence it behaves a lot differently.

Tuesday 26 October 2010 1:58:14 pm

ezpagedata is an webin operator that does page initialization in php for speed, and instead of being able to change it direclty you can customize it's result with persistent variable and / or parameter hash to operator.

plain site is old, and does not have any of this features that webin has been getting over the years, so hence it behaves a lot differently.

Thank you Andre' for your explanation.

The one where I need to pass my extension package is somebody else's eZ installation and they have made it on a plain_site basis.

Since I am passing both my extension and ezwebin extension full packages, I was wondering if by enabling the two of them in the admin back-end> Setup> Extensions> Available extensions and so realoading the extensions' autoload arrays, will this make ezpagedata() works?

Modified on Tuesday 26 October 2010 10:51:10 pm by Lo' F.

Tuesday 26 October 2010 9:21:03 pm

..by enabling the two of them in the admin back-end> Setup> Extensions> Available extensions and so realoading the extensions' autoload arrays, will this make ezpagedata() works?

..and the answer is yes!

Thursday 11 August 2011 11:01:01 pm

Hello...

I am having some problems with ezpagedata, my pagelayout menu does not display top menues, top information (tag cloud, login), left menu and bottom information.

As far as I have investigated the $pagedata  = ezpagedata() is not working at all so at page_header.tpl the following will not work: {include uri=concat('design:menu/', $pagedata.top_menu, '.tpl')}

and the menu does not appear at all.

My web site is loscated at http://www.webdesigncuba.com/index.php?/Muestra-de-trabajos/Diseno-Web-Intranet

need help.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from