eZ Community » Forums » Setup & design » How could i create a custom design ?
expandshrink

How could i create a custom design ?

How could i create a custom design ?

Monday 14 January 2008 4:28:57 am - 1 reply

I have installed the ez publish 4.0( chose the default templates "ezwebin"blunk.gif Emoticon, I just want to use a custom design( but don't want to change the default templates ). so i do followed the manual:

1. modify the file "site.ini.append.php" in "/setting/override/" as following:

[SiteSettings]
SiteList[]
SiteList[]=eng
SiteList[]=ezwebin_site_admin
SiteList[]=my_site

[SiteAccessSettings]
AvailableSiteAccessList[]
AvailableSiteAccessList[]=eng
AvailableSiteAccessList[]=ezwebin_site_admin
AvailableSiteAccessList[]=my_site

2. create a new siteaccess (named "my_site" ) in "/settings/siteaccess", and create a file "site.ini.append.php" in "/setting/siteaccess/my_site/" as following:

[DatabaseSettings]
DatabaseImplementation=ezmysql
Server=localhost
User=root
Password=XXX
Database=ezpublish
Charset=
Socket=disabled

[InformationCollectionSettings]
EmailReceiver=

[SiteSettings]
SiteName=TESTSITE
SiteURL=www.XXX.com
LoginPage=embedded
AdditionalLoginFormActionURL=http://127.0.0.1/index.php/ezwebin_site_admin/user/login

[UserSettings]
RegistrationEmail=

[SiteAccessSettings]
RequireUserLogin=false
RelatedSiteAccessList[]=my_site
ShowHiddenNodes=false

[DesignSettings]
SiteDesign=ezwebin
AdditionalSiteDesignList[]
AdditionalSiteDesignList[]=base

[RegionalSettings]
Locale=eng-US
ContentObjectLocale=eng-US
SiteLanguageList[]=eng-US
TextTranslation=disabled

[FileSettings]
VarDir=var/ezwebin_site

[ContentSettings]
TranslationList=

[MailSettings]
AdminEmail=admin@XXX.com
EmailSender=

i thought it will use default design with the codes above, but when i view "http://127.0.0.1/ezpublish/index.php" or "http://127.0.0.1/ezpublish/index.php/site/", it seems that it used the correct templates but always gave me an error message "Access denied", but i have set the codes RequireUserLogin=false in the file above, or it is because the codes in templates ?

Monday 14 January 2008 8:46:15 am

i went through the fourm and got it was because of the "Roles and policies" in admin area for new siteaccess.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from