This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » How to use the iphone templates?
expandshrink

How to use the iphone templates?

How to use the iphone templates?

Monday 01 February 2010 8:57:58 pm - 4 replies

Hi there,

in http://ez.no/ezflow/portal_management , it says "eZ Flow comes with a set of templates optimized for the iPhone."

Nice, great... but where can we find them or how can we use these templates??

After installing ez 4.2 with the most current ezflow package and demo data, there is a siteaccess "iphone". Can can access it through http://<DOMAIN>/iphone/ ... and are greeted by a one-line error message.

The message is shown, because the siteaccess is not configured at all and is unable to connect to the database.

How can we use the "comes with" templates? Why are they not enabled by default (e.g. with the iphone siteaccess), when this is one of the big announced features of ezflow? Or did i just miss something?

Searching the ez websites did not bring up anything other than the press releases in all languages. sad.gif Emoticon

Any help is appreciated.

Tuesday 02 February 2010 2:10:27 pm

Files in 4.2 ezflow version - the answer to the "find them"

/settings/siteaccess/iphone -ini.appends

/extension/ezflow/settings/siteaccess/iphone - ini.appends

/extension/ezflow/design/iphone -- the meat

/var/storage/packages/eZ-systems/ezflow_extension/ezextension/ezflow/settings/siteaccess/iphone --packaged files

Page 18 of ezflow 1.1 setup pdf has general overview and links.

Is the siteaccess enabled?

Modified on Tuesday 02 February 2010 2:23:22 pm by Doug Brethower

Wednesday 03 February 2010 7:40:11 pm

Hello Doug and all,

thanks for the fast reply. For others, who may be interessted: The official documentation for ezflow (including the said setup guide) can be found here: http://ez.no/doc/extensions/ez_flow

I had found the files in the settings and extension directory and the siteaccess was enabled.

I'm currently retrying the whole installation process and will document it:

1. Download ez 4.2 and install it. During Installation, choose the site package "eZ Flow (ver. 2.0-0)", which will be downloaded to the package directory and install nicely. I chose German language and mapped the english demo content to German. I also renamed to user siteaccess name to "ger" (instead of ezflow_site or whatever was the default)

2. You will end up with a nice ezflow site. User URL is something like http://DOMAINS.TLD/ger

3. You will have a siteaccess named "iphone". Calling it with http://DOMAINS.TLD/iphone will give you a nice "An unexpected error has occurred. Please contact the webmaster." message. Great. That's what worked for me out of the box sad.gif Emoticon

4. Looking at the error.log, you'll find, that ez cannot open the DB connection. To fix that, copy the Block [DatabaseSettings] from settings/siteaccess/ezflow_site_admin/site.ini.append.php into settings/override/site.ini.append.php and reload the page. This should define the same DB connection for all siteaccesses and get rid of the "unexpected error" message. In my case, it shows me a login screen (some permission issue?). Now, log in with the admin account.

5. You will see the frontpage in the iphone template. Unfortunetly, this seems to be complety useless: I shows the names (or types) of the frontpage, but no content, and not a single link, and no image or so. You can switch to a "Non-iphone optimized site", which brings you to /ger ... that works great

6. Browsing the site using the "ger" (or ezflow) siteaccess works great... but whenever i change the siteaccess name in the URL from "ger" to "iphone", i get something like "Module not found... The requested module 'Conference' does not exist".

Somebody got some idea?

I made it work in some other installation by manually copying lots of INI settings from "ger" to the "iphone" siteaccess settings directory and "only" using "iphone" as the primary design. But shouldn't it work out of the box?

[Edit:] Progress report:

7. To get rid of the login screen, go to your admin siteaccess and edit the "anonymous" role (http://DOMAIN/ezflow_site_admin/role/view/1). Make sure you add the siteaccess "iphone" to the user/login policy. For me, it reads "user login SiteAccess (ger, iphone)". You will probably have "ezflow_site" instead of ger

8. The missing content (in 5.+6. above) was a result of not using english language. English is the default content language, but I had no english content. So, make sure to copy the Block [RegionalSettings] along with the [DatabaseSettings] block in step 4. Please note: This will make you whole setup mono-lingual! In any case, you will need to decide on the "language" of your iphone siteaccess (or create one for each language)

9. This will make you end up with an "iphone frontpage", which now has some content, but still is pretty useless: You cannot navigate from there! But, when you navigate using the normale siteaccess and switch to "iphone" then (modify the URL!), you will get a more or less nice iphone view of your content. I think, there is a template (or templates) missing for the frontpage/it's building blocks.

10. Apart from the non-functional start page (or other "frontpage" nodes), i get an error about a missing template "tiny_image.tpl". Don't know, where this would be used. Also, the video playback in /Conference/Movies/eZ-Conference-2009-video does not work. I assume, the template is "empty" because the iphone does not support flash.

So, i hope, this is of use for somebody else.

I'm happy to see, that there are iphone template and most of them work.

I'm very unhappy, that this seems to be one of the many "hidden features" (but praised in product news/demonstrations) of ez, that simply do not work out of the box. I'm also disappointed, that the frontpage templates seem to be missing. "iphone templates" are promoted along with ezflow... To bad, that the frontpage of any ezflow installation does not work then sad.gif Emoticon

Maybe somebody can try this with a plain english setup... In many cases, this works, as the whole setup is easier.

Modified on Wednesday 03 February 2010 8:18:08 pm by Marco Zinn

Thursday 04 February 2010 2:31:34 pm

Followed along to step 5 and it works great. Looked at it from small browser window and it displays nicely optimized on the small screen with link back to main site.

I cannot speak for the eZ Flow developers, but I believe from that point you are going to have to "smallify" your site designs as you see fit. How the contents should appear on the small screen is a design decision, not something that may be easily automated. At least not yet. With eZ, who knows what the future may hold.

Thanks for keeping at it, and especially for sharing back!

Wednesday 30 May 2012 7:55:23 pm

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from