eZ Community » Forums » Setup & design » {$module_result.content} not sorting...
expandshrink

{$module_result.content} not sorting properly

{$module_result.content} not sorting properly

Tuesday 30 December 2014 11:02:19 am - 8 replies

(I hope this is the right forum for this topic)

I have å problem regarding sort order on http://www.bohemen.org/ - in the pagelayout.tpl there are no other arguments than {$module_result.content} and it is not sorting properly, either when i, from the admin interface, try date ascending/descending or priority.

Cache is cleared after every change in admin interface. Debug says nothing about something wrong.

Any clues anyone?

Regards, Atle

Wednesday 31 December 2014 5:16:23 pm

Just to clearify; there are no changes to the original 2014.07-installation. No modifications, no nothing. Just plain install.

Regards, Atle

Wednesday 31 December 2014 9:24:53 pm

Hello Atle,

Apologies for my late reply.

I think you may wish to clear your siteaccess cache manually, you seemed to have a problem with that previously.

In short almost every installation is custom in some regard or another so saying otherwise is really just not necessary.

Also the problem (if there is one) would not be found within your pagelayout template. It would be found within your node view ('full') templates used in your situation.

I can't see those in your site's debug output those are usually shown when you clear the siteaccess cache on the first page load after clearing -all- cache. 

Within say for a generic example you can review the template logic within, 'design/base/override/templates/full/folder.tpl' which may or may not be being used in your installation (you mention plain installation, does that mean you did not use any design package like ezwebin or ezdemo durring installation?).

In any case even the default template uses, '$node.sort_array' which is set via the admin on a per node basis (I think you know this).

I think your best option is to first clear all caches, then fix why your installation's cache admin is not clearing your user siteaccess cache (prolly ini settings misconfiguration).

I hope this helps!

Cheers,
Heath 

Wednesday 31 December 2014 9:28:05 pm

Hello Atle,

I took another look at your site and saw that it is now displaying the node view template as, 'design/bohemen/override/templates/full/folder.tpl'.

Now I can not tell the custom template logic your using within your full/folder.tpl template override so I can't help much there but I will say make sure your child items fetch is using:

sort_by, $node.sort_array

I hope this helps!

Cheers,
Heath 

Modified on Wednesday 31 December 2014 9:28:19 pm by // Heath

Thursday 01 January 2015 8:57:18 am

Yes Heath, that was my bad, i had a override for the full folder, but that is just a carbon copy of the original with some few items commented out. I switched back to the original, clearing the caches manually, and no change.

When installing you get two options; designpackage with data or without, I chose the one without data.

Maybe this is a 2014.07 issue? I will not see that untried, so i'll upgrade to 2014.11 before continuing to debug playing with the full node override happy.gif Emoticon

Regarding the caches in general, at this point until production the directory tree is a+rwx, so unless there are som bug in the cache clearing process from the admin interface no permission issues should be valid.

I'll also read the changelog when upgrading, might be something there.

Regards, Atle (suddenly back! blunk.gif Emoticon )

Thursday 01 January 2015 10:45:47 am

Update:

Well, the upgrade did not solve any problems, nor does the changelog mention anything regarding this matter.

So, I'll head down to the fs and start experimenting on the cc of the original node/view/full.tpl...

Reagrds, Atle

Thursday 01 January 2015 10:52:32 am

Hello Atle,

It's good to hear that you are experimenting, learning and growing.

Re: the design package choice during setup wizard, it does not change much when you choose the no-data option :\ My point was to find out if you used the ezdemo, ezwebin or plain design package to start with since this affects what templates you would be using by default.

Re: release issue. The problem your having is not specific to any version, let alone 2014.07 so upgrading to 2014.11 will in all likely hood not solve your problem nor will digging into the change log / documentation.

The problem you are having is specific to you and your installation alone.

Lets next have you explain in reproducible steps / detail what exactly you are doing to specify the node sort order in the admin. I think now you may not be doing this step correctly.

Cheers,
Heath 

Thursday 01 January 2015 11:28:59 am

Well, it works, this is scary stuff, this is what i did:

  • Not working
  • Copied the original (mine) full.tpl to full.tpl.orig
  • Edited out some whitespace, saved and cleared the cache manually (CCM) - it works
  • Copied the original (mine) back, CCM - it woks
  • Removed the override, CCM - it works
  • Added the override again, CCM - it works

I do not know what to think.... This was the only thing I did. I guess it is solved in som freaky way...

Regards, Atle

Tuesday 06 January 2015 3:57:00 am

Hello Atle,

Congratulations! I'm please you were able to solve the issue.

Thank you for marking this thread as solved.

Best wishes

Cheers,
Heath

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from