This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Multi-level subdomains and host matching
expandshrink

Multi-level subdomains and host matching

Multi-level subdomains and host matching

Monday 20 June 2011 11:46:58 am - 4 replies

Hi! I am having trouble getting the host-siteaccess mapping to work on one of my projects and I can't find any information about this yet, so I thought I'll ask it here, maybe someone knows the solution?

I have a site with 2 siteaccesses on subdomain.acceptance.domain.com and admin.subdomain.acceptance.domain.com (yes I know... too long!). My site.ini settingsare as follows:

MatchOrder=host
HostMatchType=map
HostMatchMapItems[]=subdomain.acceptance.domain.com;your_public_siteaccess
HostMatchMapItems[]=admin.subdomain.acceptance.domain.com;your_admin_siteaccess

When I try one of the above url's I end up getting a fatal error (attempts to connect to localhost with user root and no pass). This is because there is no host match. Is there support for this kind of setup, and if so, how should I configure it?

Modified on Monday 20 June 2011 5:03:34 pm by Sander van den Akker

Monday 20 June 2011 12:15:53 pm

Iin your code it seems to be a lack of siteaccess mapping. i mean, you need to map domains with siteaccess.

i see this in your code

HostMatchMapItems[]=subdomain.acceptance.domain.com
HostMatchMapItems[]=admin.subdomain.acceptance.domain.com

but it should be something like

HostMatchMapItems[]=subdomain.acceptance.domain.com;your_public_siteaccess
HostMatchMapItems[]=admin.subdomain.acceptance.domain.com;your_admin_siteaccess

 

Monday 20 June 2011 5:05:24 pm

I forgot to add those in my post, but they are in my site.ini. I have corrected my post, sorry about that!

Monday 20 June 2011 9:59:21 pm

are you sure the error message is not from database ?

Tuesday 21 June 2011 11:07:50 am

Yes, when I add the same siteaccess with a different hostname (i.e. test.domain.com) it works.

Modified on Tuesday 21 June 2011 11:08:13 am by Sander van den Akker

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from