This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Multilanguage Site Problem
expandshrink

Multilanguage Site Problem

Multilanguage Site Problem

Friday 11 July 2003 4:15:46 pm - 4 replies

Hi,
Following the instructions of the documentation, I've created 3 site.ini.append in 3 different folders (en, it, sl) under folder siteaccess and in them i put
[RegionalSettings]
Locale=eng-GB
HTTPLocale=en
ContentObjectLocale=eng-GB
for the "en" folder,
[RegionalSettings]
Locale=ita-IT
HTTPLocale=it
ContentObjectLocale=ita-IT
for the "it" folder,
[RegionalSettings]
Locale=slo-SL
HTTPLocale=sl
ContentObjectLocale=slo-SL
for the "sl" folder.
In the admin, I manage the three language (italian, english and slovenska) without any problem, but in the public site, I see always the Italian (which in my system is the default language), even if i use http://mysite/en or http://mysite/sl. I think there would be a way to choose the correct language for the nodes directly in the template that I use, but I've not found any suggestion on how to do it...
Can anybody help me?
Thank in advice.

Paolo Mellerio (Clikka!com)

Friday 11 July 2003 4:26:51 pm

Hi Paolo,

you probably have not set up the URL -> siteaccess translation correctly. See this doc:
http://ez.no/developer/ez_publish...figuration/configuration/site_access

You need to write your siteaccess rules in a way that the first part of the URI translates into the siteaccess and the rest to the module + paramenters.

Karsten

Modified on Friday 11 July 2003 4:27:38 pm by Karsten Jennissen

Friday 11 July 2003 5:48:30 pm

Thanks Karsten,

I've followed your suggestion and I modified my site.ini.append.php in the way that follows:

------------------
[SiteAccessSettings]
CheckValidity=false
MatchOrder=uri
URIMatchType=element
URIMatchElement=1
URIMatchRegexp=^/([^/]+)/
URIMatchRegexpItem=1
AvailableSiteAccessList[]=it
AvailableSiteAccessList[]=en
AvailableSiteAccessList[]=sl
AvailableSiteAccessList[]=admin
DebugAccess=enabled

[RegionalSettings]
Locale=ita-IT
ContentObjectLocale=ita-IT
TextTranslation=enabled
TranslationCache=disabled

[ContentSettings]
TranslationList=ita-IT;eng-GB;slo-SL
ViewCaching=disabled
---------------------------

but, in the public site, when I use http://mysite/en and http://mysite/sl only the italian version is shown.... have you got any idea to solve the problem?

Thanks a lot

Paolo

Saturday 12 July 2003 3:56:30 pm

Hi,,

you need to do this also ..
in settings/site.ini :

[RegionalSettings]
#Locale=eng-GB
#HTTPLocale=
#ContentObjectLocale=eng-GB

then you should make site.ini for each site, lets say for italian :
settings/siteaccess/it/
[RegionalSettings]
Locale=ita-IT
HTTPLocale=it
ContentObjectLocale=ita-IT

Monday 14 July 2003 9:12:51 am

Thanks to Karsten e to Maxim happy.gif Emoticon
All works fine now and it seems to be cool....

Paolo Mellerio (Clikka!com)

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from