This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Multiple versions of the website in...
expandshrink

Multiple versions of the website in different subtrees

Multiple versions of the website in different subtrees

Thursday 05 July 2012 1:30:29 pm - 2 replies

Hi

I'm trying to create a new version of website leaving the old one in a public archive. This is actually redesign of the webpage.

I have reconstructed the structure of the content slightly to have:

Home
--- 2012
------ News
------ Other...
--- 2011
------ News
------ Other... 

Is it possible to have URL's like:

http://mysite.com/News

which refers to Home/2012/News and

http://mysite.com/2011/News

which refers to Home/2011/News?

I created 2 siteaccess: 2012 and 2011 using configs:

# settings/siteaccess/2012/site.ini.append.php
[SiteSettings]
# Home/2012 node below
IndexPage=/content/view/full/237
DefaultPage=/content/view/full/237
PathPrefix=2012
RootNodeDepth=2
# settings/siteaccess/2012/content.ini.append.php
[NodeSettings]
RootNode=237 

and for siteaccess 2011:

# settings/siteaccess/2011/site.ini.append.php
[SiteSettings]
# Home/2011 node below
IndexPage=/content/view/full/236
DefaultPage=/content/view/full/236
PathPrefix=2011
RootNodeDepth=2
# settings/siteaccess/2011/content.ini.append.php
[NodeSettings]
RootNode=236 

but I can not achieve the desired result. My result looks like:

http://mysite.com/2011/2011/News
http://mysite.com/2012/2012/News

and what is worse to me:

http://mysite.com/2012/2011/News

Is this possible to have two independent sub-trees? In such a way that one siteaccess does not have access to not its subtree.

Cheers

Modified on Thursday 05 July 2012 1:37:35 pm by Karol Radziuk

Thursday 05 July 2012 4:15:30 pm

Hi Karol,

Is SiteAccessSettings/RemoveSiteAccessIfDefaultAccess configuration in your site.ini global override enabled? It would ensure that for 2012 siteaccess, which I presume is the default one, there would be no siteaccess name in your URLs, so that's one "2012". To get rid of the other one, you need to fix the error in your site.ini

Correct configuration for PathPrefix is SiteAccessSettings/PathPrefix, and not SiteSettings/PathPrefix.

So, to achieve desired links, your site.ini configs should look like this:

# settings/override/site.ini.append.php
[SiteSettings]
DefaultAccess=2012
 
[SiteAccessSettings]
RemoveSiteAccessIfDefaultAccess=enabled
# settings/siteaccess/2012/site.ini.append.php
[SiteSettings]
# Home/2012 node below
IndexPage=/content/view/full/237
DefaultPage=/content/view/full/237
RootNodeDepth=2
 
[SiteAccessSettings]
PathPrefix=2012
 # settings/siteaccess/2011/site.ini.append.php
[SiteSettings]
# Home/2011 node below
IndexPage=/content/view/full/236
DefaultPage=/content/view/full/236
RootNodeDepth=2
 
[SiteAccessSettings]
PathPrefix=2011

Modified on Thursday 05 July 2012 4:17:39 pm by Edi Modrić

Friday 06 July 2012 9:49:24 am

Hi Edi,

Perfect solution! I love such ones. And have posts as solved happy.gif Emoticon

Thanks!

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from