eZ Community » Forums » Setup & design » OE 5 and images

OE 5 and images

OE 5 and images

Thursday 21 May 2009 6:42:08 pm - 8 replies


In OE 4 we could select the size we wanted for the display of an image.

I would like to do the same thing with OE 5.0 so I want a selectbox where I will select the size witch will be used in my custom template.

So, after reading comments in all ini files and spent 2 days looking for a solution, I did:





Please help me before I become crazy ! sad.gif Emoticon


Thursday 21 May 2009 8:47:46 pm


Do you mean embedded images?

I added the settings to my image.ini:





Thursday 21 May 2009 9:13:25 pm

Hi Mike,

Thanks for your answer.

Yes, I mean embedded image.

I have tried your solution but nothing happends.

In OE 5.0, when you upload an image to insert it in your article, once uploaded, you can choose:
- embed
- embed-inline
- full
- line

I have added a new choice:

- myimage

When I select «myimage» I think it is possible the «New <embed> tag» dialogbox displays a dropdown menu where I can select for exemple:

- reference
- small
- medium
- large
- rss
- original

It's this dropdown menu I can't create.


Friday 22 May 2009 10:11:49 am

Pascal: It doesn't work like that.

To get image size drop down the class needs to be defined as image using the settings mentioned above. should be content.ini [RelationGroupSettings]ImagesClassList[] (and it uses class identifier, not numeric id)

If that is correct then, the ezoe/relation view (used in the background by the popup dialog when looking at embed tags properties) will pick the templates/ezoe/tag_embed_images.tpl automatically, witch includes the size drop down and image preview.

Friday 22 May 2009 12:41:00 pm

Thanks André,

Now it's really better blunk.gif Emoticon

In fact, the problem was that I don't use the default «image» class so the template use by the dialogbox of OE was extension/ezoe/design/standard/templates/ezoe/tag_embed_objects.tpl

Now I'm using the default image class, I have a problem with the image alignment on the public site wich is always on the left as you can see, for example, here:

On the link above, the tiny image should be on the right (even if I disable the debug system, the images are on the left on the public site)
In Online Editor, the image is to the right place: on the right.


Friday 22 May 2009 1:38:53 pm

Not sure, haven't used base design since 3.6 era my self.

There shouldn't be any changes in this regard in the base design recently, so has image alignment never worked on your sites? or stopped working now?

IMO: One of many reasons why one should base pages on the webin (or flow witch extends webin) design instead though, more out of the box and more used.

Friday 22 May 2009 2:31:08 pm

Hi André,

I'm sorry: a litle mistake in the /design/standard/templates/content/datatype/view/ezxmltags/embed.tpl template was the reason of the bad display.

Now all works fine.

I'm not using the ezwebin extension but the «plain» type.
Of course, while all is perfect with ezwebin, I will have to configure my templates with plain.

But I have noticed that the ezwebin Online Editor has two bottons Sup and Sub.
In my ezoe.ini this two lines:

 89 Buttons[]=sub
 90 Buttons[]=sup

are uncommented by default but the buttons are not displayed.
Is there something else to do ?

Thank's again for your help,


Friday 22 May 2009 3:29:50 pm


I have done a from scratch plain type installation and the sub and sup buttons are well displayed.

The site where I meet the problem is an upgrad from 4.0.1 to 4.1.1.
But I don't think this is the cause.


Friday 22 May 2009 3:36:21 pm

They are only displayed if you have sub and sup custom tags enabled, similar to underline button.


You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from