This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Order elements in object relations in...
expandshrink

Order elements in object relations in content/edit

Order elements in object relations in content/edit

Tuesday 12 October 2010 5:21:01 pm - 3 replies

Hi there,

I currently have a class with an "object relations".

But my problem is that : when I'm in content/edit, the list of possible objects is unordered (a single selection dropdown list)

For exemple :

  • Mario
  • Luigi
  • Koopa
  • Bowser

Instead of :

  • Bowser
  • Koopa
  • Luigi
  • Mario

If the length of the list was small it will doesn't matter... but the list is 300+ elements.

I already tried using sorting method in the folder view (because all the elements are in the same folder) but it has no effects.

And has it is a view inside ez (and not an overrided node), I can't simply alter template.

Is there a way to force elements sorting ? (using code or configuration files)

Thanks in advance,

Damien

Tuesday 12 October 2010 6:53:14 pm

Hi Damien,

Hum, your problem is weird, because if you look at the edit template of object relations datatype, the fetch function used to retrieve the possible elements has the sort_by parameter set to name. Perhaps you use an old version of eZ Publish without this behaviour or an override of this template ?

Cheers,

Modified on Tuesday 12 October 2010 6:54:32 pm by Damien Pobel

Tuesday 12 October 2010 6:58:15 pm

Hi,

A kind of solution / to try :

The object relations normally do follow the sort you set in the back office.

So :

1 - Get in the folder / container content of your 300 nodes

2 - Sort those by the criteria you want it to be sort (for example, by class or name)

3 - Go back in your content with the relation attribute

This has to work.

Friday 15 October 2010 10:20:25 am

Hi,

I tryed to setup the sort type in administration : I went to my folder and setted it up to "Name" "Ascending".

When I'm in the administration siteaccess and in content/edit, elements are sorted correctly.

When I'm in the public siteaccess and in content/edit, elements are not sorted correctly.

For information I'm running eZ 4.2.0

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from