eZ Community » Forums » Setup & design » "PHP 4.2.3 required".... does 4.2.2...
expandshrink

"PHP 4.2.3 required".... does 4.2.2 work, too?

"PHP 4.2.3 required".... does 4.2.2 work, too?

Sunday 04 May 2003 11:28:46 pm - 2 replies

For ezP3 "PHP version 4.2.3 or later" is required.
I'm running a "1&1 Root-Server", which comes with php 4.2.2. Currently, I don't experience any problems.
Upgrading to 4.2.3 won't be easy for us, as I'm not a Linux guru and there is no RPM for 4.2.3 for my (SUSE) setup.

ez: What was the reason for requestion 4.2.3?
Users: Anybody has real problems with php 4.2.2?

Modified on Sunday 04 May 2003 11:29:07 pm by Marco Zinn

Monday 05 May 2003 9:55:33 am

I remember reading that someone was successfully using it on 4.1.X so I guess that shouldn't be a problem.

Actually, upgrading is very simple, simpler if you compile it from sources than use the RPM (SuSE's a crap distribution and messes up all paths anyways so good luck with any official RPM).

I would have ordered a few of the root servers if they were running on a real OS (i.e. one of the BSDs).

Modified on Monday 05 May 2003 9:56:14 am by Gabriel Ambuehl

Monday 05 May 2003 12:42:13 pm

Marco,

There are no code requirements that need you to go to anything higher 4.1.2, but there was talk about 4.1.2 having problems with session variables not being set properly. We saw some of this,so we are upgrading to 4.3.1 or 4.3.2 (depening on the php release schedule)

Its worth upgrading to 4.3.1 if you can. 4.2.2 might be ok anyone done tests on 4.2.2?

Tony

Modified on Monday 05 May 2003 12:44:19 pm by Tony Wood

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from