eZ Community » Forums » Setup & design » Problem of linking Ez5 and Symfony
expandshrink

Problem of linking Ez5 and Symfony

Problem of linking Ez5 and Symfony

Tuesday 28 May 2013 5:28:45 pm - 2 replies

After successfully installing EZ5 on a virtual host, I don't understand how applications work. 

How to see the site in Symfony and run creates a bundle?
Because when I type the address, it directs me to the page in EZ4 and therefore doesn't symfony. So if I put in the beginning of the URL: localhost. I am redirected to the Symfony with errors.

Should we necessarily go through localhost because the virtual host has been designed?
Is there much difference between symfony and symfony in ezpublish?

Thank you.

Friday 31 May 2013 2:08:00 pm

If you installed eZ5 (or recent CP versions), and set up a vhost pointing to index.php (or index_dev.php), you will be ALWAYS running through the Symfony stack.

Some functionality from the Legacy stack is available, but it is executed via a chained router.

If you plan to use the new stack, you shoud never access directly the old controller (ezpublish_legacy/index.php)

There is no difference between "Symfony" and "Symfony in eZ".

Monday 03 June 2013 5:57:35 pm

I can't find solution.
Is it could come from my VHOST configuration?
This site is in a virtual server.
Here is my code:
NameVirtualHost MONIP:80
<VirtualHost MONIP:80>
    DocumentRoot "/var/www/vhosts/MONSITE/httpdocs/web/"
    ServerName localhost
</VirtualHost>
<VirtualHost MONIP:80>
 <Directory "/var/www/vhosts/MONSITE/httpdocs/web/">
 Options FollowSymLinks
 AllowOverride None
 # depending on your global Apache settings, you may need to uncomment and adapt
 #Allow from 127.0.0.1
 </Directory>
 
 <IfModule mod_php5.c>
 php_admin_flag safe_mode Off
 php_admin_value register_globals 0
 php_value magic_quotes_gpc 0
 php_value magic_quotes_runtime 0
 php_value allow_call_time_pass_reference 0
 </IfModule>
 
 DirectoryIndex index.php
 
 <IfModule mod_rewrite.c>
 RewriteEngine On
 
 # CVE-2012-6432
 RewriteRule ^/_internal - [R=403,L]
 
 # Uncomment in FastCGI mode, to get basic auth working.
 #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
 # v1 rest API is on Legacy
 RewriteRule ^/api/[^/]+/v1/ /index_rest.php [L]
 
 # If using cluster, uncomment the following two lines:
 #RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* /index_cluster.php [L]
 #RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* /index_cluster.php [L]
 
 RewriteRule ^/var/([^/]+/)?storage/images(-versioned)?/.* - [L]
 RewriteRule ^/var/([^/]+/)?cache/(texttoimage|public)/.* - [L]
 RewriteRule ^/design/[^/]+/(stylesheets|images|javascript|fonts)/.* - [L]
 RewriteRule ^/share/icons/.* - [L]
 RewriteRule ^/extension/[^/]+/design/[^/]+/(stylesheets|flash|images|lib|javascripts?)/.* - [L]
 RewriteRule ^/packages/styles/.+/(stylesheets|images|javascript)/[^/]+/.* - [L]
 RewriteRule ^/packages/styles/.+/thumbnail/.* - [L]
 RewriteRule ^/var/storage/packages/.* - [L]
 
 # Makes it possible to place your favicon at the root of your
 # eZ Publish instance. It will then be served directly.
 RewriteRule ^/favicon\.ico - [L]
 # Uncomment the line below if you want you favicon be served
 # from the standard design. You can customize the path to
 # favicon.ico by changing /design/standard/images/favicon\.ico
 #RewriteRule ^/favicon\.ico /design/standard/images/favicon.ico [L]
 RewriteRule ^/design/standard/images/favicon\.ico - [L]
 
 # Give direct access to robots.txt for use by crawlers (Google,
 # Bing, Spammers..)
 RewriteRule ^/robots\.txt - [L]
 
 # Platform for Privacy Preferences Project ( P3P ) related files
 # for Internet Explorer
 # More info here : http://en.wikipedia.org/wiki/P3p
 RewriteRule ^/w3c/p3p\.xml - [L]
 
 # Uncomment the following lines when using popup style debug in legacy
 #RewriteRule ^/var/([^/]+/)?cache/debug\.html.* - [L]
 
 # Following rule is needed to correctly display assets from eZ Publish5 / Symfony bundles
 RewriteRule ^/bundles/ - [L]
 
 RewriteRule .* /index.php
 </IfModule>
 
 DocumentRoot /var/www/vhosts/MONSITE/httpdocs/web/
 ServerName MONSITE
 ServerAlias MONSITE
 
</VirtualHost>

A fault is present?

Thank you

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from