eZ Community » Forums » Setup & design » [SOLVED] 3.10.0 - no tree structure...
expandshrink

[SOLVED] 3.10.0 - no tree structure (items, user, media)

[SOLVED] 3.10.0 - no tree structure (items, user, media)

Wednesday 24 October 2007 6:09:36 pm - 19 replies

<b>fresh installed 3.10.0 - doesn't display the tree structure (items, user, media) in admin Interface (tree-structure-screen)</b>

if somebody here to give me a tip - how can i fix this problem - it wasn't in my last installation (3.9.2).
now in the "structure-window" of admin interface is only displayed the root-node item without chance to expand it (no +) and the popup menu allowed only collapse - but all subitems are displayed in the subitem -screen.

what i can do - to became the tree view?

thanx
bernd

Modified on Tuesday 06 November 2007 2:10:04 pm by Bernd Winkelmann

Wednesday 24 October 2007 6:29:40 pm

I am also experiencing this problem on a fresh install of 3.10, but have not had time to troubleshoot. The only thing I did check is that contentstructuremenu.ini seems to be properly configured.

Wednesday 24 October 2007 6:46:32 pm

Hi,

Had the same problem too. You just have to replace :

RewriteRule content/treemenu/?$ index_treemenu.php
RewriteRule index_treemenu.php - [L]

by :

RewriteRule content/treemenu/?$ /index_treemenu.php [L]

in your .htaccess

Thanks to Kare happy.gif Emoticon
http://ez.no/developer/forum/inst...m_with_new_admin_dynamic_treemenu__5

Wednesday 24 October 2007 7:02:27 pm

ohh no - that is not the solution in my case - i have done it before i posted this problem here.

Wednesday 24 October 2007 8:07:54 pm

using Firebug I see that the ajax request for the treemenu is: http://myhost.de/index.php?/ezweb...erm=43b864bde60564a9abad0598b1d5d203

but as response is there not a json object - but a errorpage is resonsed:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de-DE" lang="de-DE">

<head>

<title>kernel (1) / Fehler - Website Interface</title>

thanx for help
bernd

Wednesday 24 October 2007 8:19:12 pm

Try changing these settings in contentstructuremenu.ini -

[TreeMenu]
# If set to enabled, the admin tree menu is fetched and built dynamically on
# fly. Requires a web browser with AJAX support.
Dynamic=enabled

# If set to enabled, the JSON documents will be also cached on the server.
UseCache=enabled

I was messing with some things and got it to work, but of course I changed several things at once so I am not sure what did it.

Wednesday 24 October 2007 9:08:26 pm

wow - possible that the enabled cache for the json response is not cleaned by the admin cache clean up.

but i tried it now deleting manually all caches - no other result

for me is enough for today - the dynamic menu is not working here because the response is not valid.

from errorlog:
[ Oct 24 2007 20:53:29 ] [87.187.193.23] error/view.php:
Error ocurred using URI: /index.php?/ezwebin_site_admin/content/treemenu?node_id=2&modified=1193235666&expiry=1193251869&perm=43b864bde60564a9abad0598b1d5d203

so i will using the static tree - is ok

thanx for ya care
bernd

Thursday 25 October 2007 10:12:41 am

Hi,

According to the url that you show, I suppose you are in CGI mode aren't you ?

Somebody can confirm that this new content structure tree doesn't work in cgi mode ?

The RewriteRule cannot work in this way .

In cgi mode with

/index.php?/ezwebin_site_admin/content/treemenu?node_id=2...

the rewriterule wokr for an url of this type :

/index.php/ezwebin_site_admin/content/treemenu?node_id=2...

Can you confirm that you are in cgi mode ?

If not, ignore my message :s
++

Thursday 25 October 2007 12:39:01 pm

hi

ok - yes my php is running as cgi module.

but i doesn't understand why the system is not resolving the querystring in this mode internal

thanx
bernd

Tuesday 06 November 2007 2:19:09 pm

ok the problem was the link structure resulting from php fast cgi mode ....index.php?/....

now i'm running system in virtualhost environment using host access method with ForceVirtualHost=true and the treemenue works fine.

my setup adventure: http://ez.no/content/view/full/152580

thanks for all hints
bernd

Friday 16 November 2007 5:34:45 am

Another side note for anyone facing this issue. During the 3.10.0 upgrade process when I ran bin/php/updateniceurls.php it failed for some reason and changed all the lowest node url to a number. This subsequently caused the ajax menu to fail. My solution was to edit and republish the main node.

Friday 16 November 2007 9:36:25 am

Bug report about fastcgi incompatibility: http://issues.ez.no/11806
Bug report related to nodes with number title: http://issues.ez.no/11850

Saturday 08 December 2007 5:34:12 pm

Sorry to barge in on this thread, but I have the original problem without having the possibility to do the virtual host workaround, and the problem is still found on the new 4.0 release.

Are there any other workarounds available?

Sunday 09 December 2007 11:42:03 pm

Hello hello!

Having the same issue with 3.10.
In CGI mode, i cannot get the admin menu to work , it only displays the root menu.

Is there any way to turn back the admin menu to a good old html or javascript menu?

Thanks and enjoy!
Manu

Monday 10 December 2007 3:07:15 pm

> Is there any way to turn back the admin menu to a good old html or javascript menu?

Yes, and it is indirectly described in the 3.9 -> 3.10 upgrade doc.

contentstructuremenu.ini:

[TreeMenu]
Dynamic=disabled

Wednesday 12 December 2007 5:23:18 pm

Any ideas for how I might be able to get the content structure tree working in eZ 4 when running php as cgi?

[TreeMenu] Dynamic is already set to "disabled."

Wednesday 12 December 2007 6:47:20 pm

I think I may have the solution you are looking for regarding the menu not working in dynamic mode:

http://issues.ez.no/IssueView.php?Id=12244

Hope this helps!

Wednesday 09 January 2008 10:37:37 am

thanks david, that's the solution for me (non cgi-mode php)

Sunday 03 February 2008 7:34:56 am

Can anyone clarify this issue? I'm a bit new to eZ. Seems several people are having trouble.
I still can't get this resolved. Here is my phpinfo:
http://bhenkel.echoechoplus.com/info.php

Thanks.

Modified on Sunday 03 February 2008 7:59:51 am by Brian Henkel

Monday 31 March 2008 5:23:31 pm

Hello. I'm having the problem of not being able to use the content tree with php running in cgi mode and my site configure with a url access mode.

What I did:

Set the [TreeMenu] Dynamic=disabled, then i see the first level directories, but i can't browse the tree with AJAX

Set the [TreeMenu] Dynamic=enabled. I see just the root directory.

With firebug i see the Ajax request to:
[SITE]/index.php?/[SITE_ACCESS]/content/treemenu?node_id=2&modified=1206952627&expiry=1206976204&perm=db4f51c5983110e80e4ea269d6c9a60f

which is not risolved in the right way cause of the 2 question marks

I try using and playing a bit with the traslation rules suggested in http://issues.ez.no/IssueView.php?Id=12244:
getting:
[SITE]/index_treemenu.php?node_id=2&modified=1206952627&expiry=1206976204&perm=db4f51c5983110e80e4ea269d6c9a60f (which does not work, get a "Forbidden. You don't have permission to access" error message)

in a test site (php running as apache module) i can make index_treemenu working with this kind of link:
[SITE]/index_treemenu.php/[SITE_ACCESS]/?node_id=2&modified=1206952627&expiry=1206976204&perm=db4f51c5983110e80e4ea269d6c9a60f
(but this will not work with a cgi configuration cause of the double question mark).

Does anybody know how to solve the tree problem with php as cgi and url site access mode? Or has any good suggestion for me?

Thanks
Nicola

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from