eZ Community » Forums » Setup & design » [solved] Multi siteacces : BO problem
expandshrink

[solved] Multi siteacces : BO problem

[solved] Multi siteacces : BO problem

Monday 16 March 2015 12:03:10 pm - 5 replies

Hi to all,

I'm triying to add a new siteaccess to my ezp 5 web site. The goal is to have a new database, new Back Office and a new design on the same install of EZP.

For that, I create a new extension :

  • I have duplicate ezwebin extension to a new one ( named test ), change all references to "ezwebin" in it ( settings, link in css, etc... ).
  • I create a new siteacces, by duplicating an old one to a new one (test), enabled it in /override/site.ini.append.php.
  • I enabled my extension in the settings/override/site.ini.append.php and that's work : my new design is applied.

For the Back Office :

  • Duplicate admin directory to test_admin.
  • Change all references to admin to test_admin.
  • enabled my test_admin siteaccess in settings/override/site.ini.append.php

For the database :

  • I've duplicate the old one to a new one, create a new MySQL user and give him full right access to tables.
  • Update test and test_admin site.ini.append.php with the new database settings ( database, user, ... )

Now, I've got 2 news siteaccess ( test and test_admin ) and test have it's own design. BUT I can't edit any content from the back Office !

In the log error, I've got the above error :

Unknown template variable 'pagedata' in namespace ''
eZTemplate @ extension/test/design/test/templates/canonical_link.tpl:1[0]:
Unknown template variable 'pagedata' in namespace ''
eZTemplate @ extension/test/design/test/templates/page_header_searchbox.tpl:10[4]:
Unknown template variable 'pagedata' in namespace ''

I don't understand where this error comes from, because I don't have it from the old back office. Did I forget something ?

Anny help will  be appreciate.

Regards.

Alex.

Modified on Monday 16 March 2015 3:36:40 pm by Peretjatko Alexandre

Monday 16 March 2015 12:45:50 pm

Have you tried to regenerate the table of classes used by the system extensions of your new extension??

Monday 16 March 2015 1:35:47 pm

By "regenerate the table of classes" do you meen generateautolads ?

Yes, I've execute php bin/php/ezpgenerateautoloads.php, but it doesn't change the behaviour.

Monday 16 March 2015 2:33:31 pm

Hi Alex,

Have a look at this :

http://share.ez.no/forums/setup-design/unknown-template-variable

Hope it helps.

 

By the way can you help me, purhaps you have the answer  :
http://share.ez.no/forums/setup-design/can-t-send-email-smtp-in-ez-publish-5.4

Monday 16 March 2015 3:33:18 pm

I found the problem !

In the /override/site.ini.append.php you can not acces to a same siteaccess with a different domain name !!!!

You can't have :

[SiteAccessSettings]
MatchOrder=uri;host
HostMatchMapItems[]=test1.mydomain.com;mysiteaccess
HostMatchMapItems[]=test2.mydomain.com;mysiteaccess
You shoud have :
[SiteAccessSettings]
MatchOrder=uri;host
HostMatchMapItems[]=test1.mydomain.com;mysiteaccess
HostMatchMapItems[]=test2.mydomain.com;myOthersiteaccess

Modified on Monday 16 March 2015 3:35:40 pm by Peretjatko Alexandre

Monday 16 March 2015 3:48:37 pm

Good, I'm happy to hear that big-smile.gif Emoticon
By the way can you help me, purhaps you have the answer  :
http://share.ez.no/forums/setup-design/can-t-send-email-smtp-in-ez-publish-5.4
Thanks in adavance.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from