This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » [solved] Overriding infocollector...
expandshrink

[solved] Overriding infocollector view template

[solved] Overriding infocollector view template

Friday 14 November 2014 2:37:19 pm - 4 replies

Hi to all,

That's drive me crazy : I can't override a template view.

My template source : <site>/design/admin/templates/infocollector/view.tpl

My custom template : <site>/extension/<MyExtension>/design/<MyExtension>/override/templates/infocollector/formulaire.tpl

So, in my override.ini I've add this section :

<span style="font-size: 1.1em;">[infocollector_formulaire]</span>
 
Source=infocollector/view.tpl
 
MatchFile=infocollector/formulaire.tpl
 
Subdir=templates
 
Match[class_identifier]=formulaire

But nothing happen after clearing the cache. What's wrong with my override ?

Note : I tried to change the overrride condition with :Match[view]=default... but without success.

Any suggestions are welcome.

Regards

Alex.

Modified on Friday 14 November 2014 4:19:54 pm by Peretjatko Alexandre

Friday 14 November 2014 3:14:47 pm

Hello Peretjatko,

You could be having a number of issues.

1. Does your extension have a extension/<MyExtension>/settings/design.ini.append.php file loading your custom design templates?

<?php /* #?ini charset="utf-8"?
 
[ExtensionSettings]
 
DesignExtensions[]=MyExtensionFolderNameString
 
*/ ?>

2. Where is your customized override.ini file located. Please share the full path to this file.

2.1 Note: You should prolly rename your override.ini file to override.ini.append.php

3. To my knowledge you can not use content module template override conditions using the infocollector module view.

Instead you will need to rename your template override file name to match the original template file name.

You'll also need to store the modified template in the extension/<MyExtension>/design/<MyAdminDesignFolderNameString>/templates/infocollector directory.

4. You'll also want to ensure that your extension's design folder is loaded by your siteaccess settings.

You have some work ahead of you but I just know what you want to do is possible and you can reach your goals!

I hope this helps!

Cheers,
Heath

Modified on Friday 14 November 2014 3:15:19 pm by // Heath

Friday 14 November 2014 3:31:24 pm

Hello Heath,

Thanks for your repli.

I've solve my problem with your help : My template was with a wrong name in the wrong place, so the correct settings are :

[infocollector_formulaire]

Source=infocollector/view.tpl

MatchFile=infocollector/view.tpl

Subdir=templates

Match[class_identifier]=default

And my file have to be located in :

extension/<MyCustomExtension>/design/admin/templates/infocollector/view.tpl

I've put in bold all the changes.

Thanks again Heath,

Alex.

Friday 14 November 2014 3:57:21 pm

Hello Peretjatko,

I'm very pleased to hear you have solved your problems.

I still am convinced the override.ini rule ini settings are not required for this / your template override.

Thank you so much for communicating so clearly in your last message, it really helps!

Can you check the check box icon at the top of this thread and mark this thread as solved?

Best wishes!

Cheers,
Heath 

Modified on Friday 14 November 2014 4:06:51 pm by // Heath

Friday 27 February 2015 12:24:09 pm

The reply has been removed because of violation of forum rules.

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from