This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » Survey: submit error with «Form...
expandshrink

Survey: submit error with «Form receiver» attribut

Survey: submit error with «Form receiver» attribut

Sunday 04 April 2010 3:09:45 pm - 1 reply

Hi,

Each time I add a «Form receiver» attribut in a survey I get this error message:

Fatal error:  Call to undefined function templateInit() in /var/www/test/ez43webin/extension/ezsurvey/datatypes/ezsurvey/ezsurveytype.php
 on line 377
 
Fatal error: eZ Publish did not finish its request
The execution of eZ Publish was abruptly ended, the debug output is present below.

when a user submits the form.

Pascal

Modified on Sunday 04 April 2010 3:13:24 pm by Pascal France

Tuesday 06 April 2010 11:37:29 am

HI Pascal,

It seems the ezsurvey extension has not been updated to comply with eZ Publish 4.3. If you take a look at the release annoucement ( http://share.ez.no/blogs/ez/ez-publish-4.3.0-released ), it reads :

templateInit() has been deprecated, so in the future calls to  to get template instance should go via ezTemplate::factory()

So, as a short-term solution you can replace the calls to templateInit() accordingly. As a proper solution, i'd suggest to modify the extension itself in there http://projects.ez.no/ezsurvey_ezp4. Should be at least suggested in the forums.

Thanks for pointing this Pascal,
Cheers,

Modified on Tuesday 06 April 2010 11:38:03 am by Nicolas Pastorino

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from