This site has been archived and you can no longer log in or post new messages. For up-to-date community resources please visit ezplatform.com

eZ Community » Forums » Setup & design » user[at]home[dot]com
expandshrink

user[at]home[dot]com

user[at]home[dot]com

Monday 21 July 2003 2:16:55 pm - 2 replies

Is there a trick to get emailadresses to display properly? Now it's displayed as user[at]home[dot]com.. It's clickable and the mailto: works fine, but it's not displayed with @ and regulad dots '.'.

Another user also posted this question under /developer earlier, but got not feedback..

Monday 21 July 2003 2:36:26 pm

You could try this...

In your site.ini.append.php, change

[TemplateSettings]
Debug=disabled

to

[TemplateSettings]
Debug=enabled

Find out which template is used (probably a standard-template).
Copy this to your corresponding override folder, and alter the template to suite your needs.

Regards Bjørn

Monday 21 July 2003 2:47:37 pm

Thanks again Bjørn, the debugging worked out:

To others with the same problem, turn on debug as described in previous messagen in this thread - in my case the file called was : design/standard/override/templates/content/datatype/view/ezauthor.tpl

I copied this to my designs corresponding folder and modified the last {$Author:item.email|wash(mail)} to {$Author:item.email|wash(xhtml)}. Voila!

End result:

{section name=Author loop=$attribute.content.author_list sequence=array(bglight,bgdark) }
{$Author:item.name|wash(xhtml)} - ( <a href="mailto:{$Author:item.email|wash(xhtml)}">{$Author:item.email|wash(xhtml)}</a> )

{delimiter}
,
{/delimiter}
{/section}

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from