eZ Community » Forums » Suggestions » Wrong PHP version?
expandshrink

Wrong PHP version?

Wrong PHP version?

Tuesday 04 July 2006 3:21:15 pm - 4 replies

I get this error message:

<b>Unsupported PHP version 4.4.2

You cannot use this PHP version with eZ publish 3.6.1.
You will need to upgrade to eZ publish version 3.7 or higher.</b>

but I have installed the last version 3.8.0/3.8.1

What is wrong? Whre is the neccecary version defined?

Regards
Martin

Modified on Tuesday 04 July 2006 3:43:38 pm by Martin Falley

Wednesday 05 July 2006 1:23:08 pm

Hello Martin

Welcome to the eZ community!

Can you tell us exactly which version you've installed?

Wednesday 05 July 2006 1:47:42 pm

I was shure, it is the 3.8.0/3.8.1

Unfortunatly I think, I was on the wrong server sad.gif Emoticon( and the Version is lower than 3.8

Anything between 3.6 and 3.7

But on the other server, where is version 3.8.1 installed i get the Error

<b>Fatal error: Call to undefined function: var_export() in /mnt/kw2/05/420/00000010/htdocs/cms/ez/lib/ezutils/classes/ezini.php on line 502</b>

Regards
Martin

Wednesday 05 July 2006 1:58:45 pm

I was shure, it is the 3.8.0/3.8.1

It is either 3.8.0 or 3.8.1, or if it's something in between then please specify the subversion revision number.

Regarding the error message about the undefined function var_export(): var_export is available since PHP 4.2.0 ( http://www.php.net/manual/en/function.var-export.php ), so if you're running PHP 4.4.2 it should be there. Maybe your web hosting provider has disabled it with the disable_functions directive in php.ini ( see http://www.php.net/manual/en/features.safe-mode.php )?

Wednesday 05 July 2006 3:52:31 pm

I controlled the versionnumber and it is ezpublish-3.8.1-gpl from the ezpublish-3.8.1-gpl.tar.gz

Now I will ask my provider, what is wrong and how we can fix the problems.

Thanks for now

Best regards
Martin from Hamburg, Germany

expandshrink

You must be logged in to post messages in this topic!

36 542 Users on board!

Forums menu

Proudly Developed with from